Project

Profile

Help

Issue #529

'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f6c750>>

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
The nodes unittests print lots of errors to the screen when run in Python 2.6. The errors are of the form "Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2bc6950>> ignored".

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Every time

Steps to Reproduce:
1. nosetests -sx nodes/test/unit

Actual results:
(pulp)[rbarlow@notepad]~/devel/pulp% nosetests -sx nodes/test/unit
.................................../home/rbarlow/devel/pulp/server/pulp/server/db/connection.py:140: DeprecationWarning: The safe parameter is deprecated. Please use write concern options instead.
return method(*args, **kwargs)
.......................................................................Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2bc6950>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2bc64d0>> ignored
.......Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f62410>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f0d1d0>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2da1c10>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f5a090>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2dd7350>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2dd9450>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f5ba10>> ignored
...........Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f5a810>> ignored
....Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f6c610>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f6c650>> ignored
.Exception AttributeError: "'NoneType' object has no attribute 'closed'" in <bound method UnitWriter.__del__ of <pulp_node.manifest.UnitWriter object at 0x2f6c750>> ignored

Expected results:
The above command should only print dots and the end of test report.

+ This bug was cloned from Bugzilla Bug #1142304 +

History

#1 Updated by cduryee over 6 years ago

Setting as medium/2.5.1 to determine if error is due to unit tests or if it can be repro'd at runtime.

+ This comment was cloned from Bugzilla #1142304 comment 1 +

#3 Updated by cduryee over 6 years ago

merged to 2.5-dev and master

+ This comment was cloned from Bugzilla #1142304 comment 3 +

#4 Updated by cduryee over 6 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1142304 comment 4 +

#5 Updated by pthomas@redhat.com over 6 years ago

Please have a dev verify it.

+ This comment was cloned from Bugzilla #1142304 comment 5 +

#6 Updated by cduryee over 6 years ago

These errors no longer appear.

+ This comment was cloned from Bugzilla #1142304 comment 6 +

#7 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#8 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF