Project

Profile

Help

Maintenance. Planio will be undergoing a scheduled maintenance this weekend. Between Saturday, July 24 at 9:00 UTC and Sunday, July 25, 22:00 UTC your account might observe occasional downtimes which may last up to several minutes in some cases.

Issue #518

/etc/pulp/repo_auth.conf doesn't have in-code defaults like our other config files have

Added by rbarlow over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Currently there is no way to specify all of the config defaults for repo_auth.conf. In fact, most of those settings are required to be present, or the WSGI access script will fail.

Version-Release number of selected component (if applicable):
2.4.0

How reproducible:
Every time

Steps to Reproduce:
1. Make repo_auth.py empty.
2. Restart apache.
3. Try to access a protected repository.

Actual results:
The access script will fail due to the values in repo_auth being required.

Expected results:
There should be sane defaults for all settings in repo_auth.conf.

+ This bug was cloned from Bugzilla Bug #1140823 +

History

#1 Updated by bmbouter over 6 years ago

  • Severity changed from Low to 1. Low

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF