Project

Profile

Help

Story #5080

closed

Story #3821: As a user, I can migrate from Pulp 2 to Pulp 3

As a user, I can track which tasks were using a specific Migration Plan

Added by ttereshc over 3 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

A relation between a Migration Plan and migration tasks which were running based on this migration plan is needed.

Solution

  • Add tasks field to the MigrationPlan model
  • Update its serializer
  • Make sure the relation is set when the main migration task is run.
  • Allow filtering by task href

Related issues

Is duplicate of Pulp - Story #5120: As a user, I can filter tasks by their 'reserved_resources'CLOSED - CURRENTRELEASElmjachky

Actions
Actions #1

Updated by ttereshc over 3 years ago

  • Project changed from RPM Support to Pulp
Actions #2

Updated by ttereshc over 3 years ago

  • Parent task set to #3821
Actions #3

Updated by ttereshc over 3 years ago

  • Description updated (diff)
Actions #4

Updated by ttereshc over 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc
Actions #5

Updated by ttereshc over 3 years ago

  • Status changed from ASSIGNED to POST
Actions #6

Updated by ttereshc over 3 years ago

  • Status changed from POST to CLOSED - DUPLICATE
Actions #7

Updated by ttereshc over 3 years ago

  • Is duplicate of Story #5120: As a user, I can filter tasks by their 'reserved_resources' added
Actions #8

Updated by ttereshc over 3 years ago

This use case will be possible to satisfy with the story #5120.

Actions #9

Updated by ttereshc about 3 years ago

  • Project changed from Pulp to Migration Plugin

Also available in: Atom PDF