Project

Profile

Help

Task #4388

closed

Upgrade to Celery 4.3

Added by dalley over 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Celery 4.3 is the last Celery release supporting Python 2. We should go ahead and upgrade now, as it's likely that all upstream bugfix effort going forwards will be made against 4.3.

https://github.com/celery/celery/issues/5180


Related issues

Related to Pulp - Issue #4387: Epel is shipping a new version of celery which doesn't work with PulpCLOSED - CURRENTRELEASEActions
Actions #1

Updated by CodeHeeler over 3 years ago

  • Tracker changed from Issue to Task
  • % Done set to 0
Actions #2

Updated by bmbouter over 3 years ago

I'm concerned about switching versions at all due to quality issues in upstream Celery. For example this regression in 4.2. https://github.com/celery/celery/issues/3802#issuecomment-407024765

I'm not opposed to upgrading, it's just something to think about.

Actions #3

Updated by daviddavis over 3 years ago

  • Related to Issue #4387: Epel is shipping a new version of celery which doesn't work with Pulp added
Actions #4

Updated by bmbouter about 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #5

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added
Actions #6

Updated by bmbouter almost 2 years ago

  • Tags deleted (Release Engineering)

Also available in: Atom PDF