Project

Profile

Help

Issue #4276

Ostree repo with custom depth set returns error

Added by jomitsch@redhat.com almost 2 years ago. Updated about 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - OSTree:
Platform Release:
Target Release - OSTree:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I have am syncing 'Red Hat Enterprise Linux Atomic Host Trees' from 'https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo' and it is raising an error:

Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: celery.app.trace:INFO: [85de4532] Task pulp.server.async.tasks._release_resource[85de4532-2637-499f-832a-2c62c41ad3a0] succeeded in 0.0162214790003s: None
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2105]: celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._release_resource[a7baf6c3-d5d2-4d12-9607-fb8ac52a64b2]
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480) Exception caught from plugin during publish for repo [a4931609-ba3f-43ce-9d18-5a13bda61028]
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480) Traceback (most recent call last):
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 1259, in _do_publish
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     publish_report = publish_repo(transfer_repo, conduit, call_config)
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 737, in wrap_f
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     return f(*args, **kwargs)
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp_ostree/plugins/distributors/web.py", line 87, in publish_repo
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     return self._publisher.process_lifecycle()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 572, in process_lifecycle
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     super(PluginStep, self).process_lifecycle()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 163, in process_lifecycle
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     step.process()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 256, in process
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     self._process_block()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 303, in _process_block
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     self.process_main()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)   File "/usr/lib/python2.7/site-packages/pulp_ostree/plugins/distributors/steps.py", line 92, in process_main
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480)     raise pe
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.controllers.repository:ERROR: [eaaf0d9c] (2863-48480) PulpCodedException: Pulling local refs failed. Reason: GLib.Error('Importing 4330ddfb4b9f84c63edcea17928cd5cf1f8688e3e3297a63c18097defebf97a4.commit: linkat: No such file or directory', 'g-io-error-quark', 1)
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: pulp.server.async.tasks:INFO: [eaaf0d9c] Task failed : [eaaf0d9c-9afd-4d2e-b2ae-b688b0ca0c46] : Pulling local refs failed. Reason: GLib.Error('Importing 4330ddfb4b9f84c63edcea17928cd5cf1f8688e3e3297a63c18097defebf97a4.commit: linkat: No such file or directory', 'g-io-error-quark', 1)
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: celery.app.trace:INFO: [eaaf0d9c] Task pulp.server.managers.repo.publish.publish[eaaf0d9c-9afd-4d2e-b2ae-b688b0ca0c46] raised expected: PulpCodedException()
Dec 18 15:55:06 coffee.jomitsch.example.com pulp[2863]: celery.app.trace:INFO: [a7baf6c3] Task pulp.server.async.tasks._release_resource[a7baf6c3-d5d2-4d12-9607-fb8ac52a64b2] succeeded in 0.00120918099992s: None

Here are the repo details

Id:                   a4931609-ba3f-43ce-9d18-5a13bda61028
Display Name:         Red Hat Enterprise Linux Atomic Host Trees
Description:          None
Content Unit Counts:  
  Ostree: 2
Notes:                
Scratchpad:           
  Remote: 
    Summary: 
      Commit:   cbdf1df91ffb370cad574ad2bfdcf5e9999629437e23e620055af0dbef2c0cae
      Metadata: 
        Version: 7.6.1.1
      Name:     rhel-atomic-host/7/x86_64/standard
Importers:            
  Config:               
    Depth:           1
    Feed:            https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x
                     86_64/ostree/repo
  <ssl info removed>
   SSL Validation:  True
  Id:                   ostree_web_importer
  Importer Type Id:     ostree_web_importer
  Last Override Config: 
  Last Sync:            2018-12-18T15:55:06Z
  Last Updated:         2018-12-18T15:54:32Z
  Repo Id:              a4931609-ba3f-43ce-9d18-5a13bda61028
  Scratchpad:           None
Distributors:         
  Auto Publish:         True
  Config:               
    Depth:         1
    Relative Path: Default_Organization/Library/content/dist/rhel/atomic/7/7Serv
                   er/x86_64/ostree/repo
  Distributor Type Id:  ostree_web_distributor
  Id:                   a4931609-ba3f-43ce-9d18-5a13bda61028
  Last Override Config: 
  Last Publish:         2018-12-18T15:54:30Z
  Last Updated:         2018-12-18T15:54:32Z
  Repo Id:              a4931609-ba3f-43ce-9d18-5a13bda61028
  Scratchpad:           

Versions:
[root@coffee ~]# rpm -qa | grep ostree
ostree-2018.5-1.el7.x86_64
python-pulp-ostree-common-1.3.1-1.el7.noarch
pulp-ostree-plugins-1.3.1-1.el7.noarch
[root@coffee ~]# rpm -qa | grep pulp
rubygem-smart_proxy_pulp-1.3.0-1.el7.noarch
pulp-client-1.0-1.noarch
python-pulp-common-2.18.0-0.1.beta.el7.noarch
pulp-rpm-handlers-2.18.0-0.1.rc.el7.noarch
libsolv-0.6.34-2.pulp.el7.x86_64
python-pulp-deb-common-1.8.0-1.el7.noarch
python-pulp-bindings-2.18.0-0.1.rc.el7.noarch
python-pulp-docker-common-3.2.2-0.1.beta.el7.noarch
pulp-selinux-2.18.0-0.1.beta.el7.noarch
pulp-katello-1.0.2-1.el7.noarch
python-pulp-oid_validation-2.18.0-0.1.beta.el7.noarch
pulp-deb-plugins-1.8.0-1.el7.noarch
pulp-puppet-plugins-2.18.0-0.1.beta.el7.noarch
python-pulp-agent-lib-2.18.0-0.1.rc.el7.noarch
pulp-admin-client-2.18.0-0.1.rc.el7.noarch
python-pulp-repoauth-2.18.0-0.1.beta.el7.noarch
python-pulp-rpm-common-2.18.0-0.1.beta.el7.noarch
python2-solv-0.6.34-2.pulp.el7.x86_64
pulp-rpm-plugins-2.18.0-0.1.beta.el7.noarch
python-pulp-puppet-common-2.18.0-0.1.beta.el7.noarch
pulp-rpm-admin-extensions-2.18.0-0.1.rc.el7.noarch
python-pulp-client-lib-2.18.0-0.1.rc.el7.noarch
pulp-docker-plugins-3.2.2-0.1.beta.el7.noarch
python-pulp-ostree-common-1.3.1-1.el7.noarch
pulp-ostree-plugins-1.3.1-1.el7.noarch
pulp-server-2.18.0-0.1.beta.el7.noarch
python-pulp-streamer-2.18.0-0.1.beta.el7.noarch

This appears like a duplicate of https://pulp.plan.io/issues/2552 at first, but it looks like that has already been resolved and should be fixed with the versions used here.


Related issues

Is duplicate of OSTree Support - Issue #3999: Publishing incorrect branch head.CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jortel@redhat.com almost 2 years ago

This was fixed with https://pulp.plan.io/issues/3999 and should be released in pulp-ostree 1.4.

I tested a sync with https://cdn.redhat.com/content/dist/rhel/atomic/7/7Server/x86_64/ostree/repo and depth=1 using pulp-ostree 1.4a1 and it completed and published successfully.

#2 Updated by daviddavis almost 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Per comment 1, closing as a dupe of #3999.

#3 Updated by daviddavis almost 2 years ago

  • Is duplicate of Issue #3999: Publishing incorrect branch head. added

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF