Project

Profile

Help

Issue #3909

auto_decompress of Downloaders modifies binary data downloaded

Added by bmbouter about 1 year ago. Updated 6 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
3. High
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 41

Description

If you use the auto_decompress=False option, the file saved by the downloader to the temporary area is expected to be byte-for-byte idential binary data as the remote source. Due to a bug in aiohttp, this is not the case.

This causes DigestValidationErrors to be raised when downloading with DeclarativeVersion because the ArtifactDownloader specifies auto_decompress=False.

This issue is reproduced outside of Pulp and is tracked in upstream aiohttp here: https://github.com/aio-libs/aiohttp/issues/3182

I'm advocating to temporarily disable digest/size validation used by ArtifactDownloader until this issue is resolved.


Checklist

History

#1 Updated by CodeHeeler about 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 41

#2 Updated by bmbouter about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to bmbouter

#3 Updated by bmbouter about 1 year ago

  • Status changed from ASSIGNED to CLOSED - NOTABUG

This was reproducable by the Python unit tests, but actually the root cause is the content-encoding response from the repos.fedorapeople.com server. I filed as issue for it here: https://pagure.io/fedora-infrastructure/issue/7161

The auto_decompress feature has also been negative committed. I'm closing this as NOTABUG since it's working. The workaround for now is to sync from upstream sources like PyPI instead of fixture data from repos.fedorapeople.com.

#4 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#5 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF