Project

Profile

Help

Issue #380

Role - different id in request and response

Added by pbartiko almost 7 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.2
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Request for create role expects "role_id", but in response is only "id".

How reproducible:
always

Steps to Reproduce:
1. create role

Actual results:
post role_id
get id

Expected results:
post id
get id

Additional info:
https://pulp-dev-guide.readthedocs.org/en/pulp-2.2/integration/rest-api/role/cud.html

+ This bug was cloned from Bugzilla Bug #1021962 +

History

#1 Updated by cduryee almost 7 years ago

This is still outstanding as of 2.4.3

from server_calls.log when creating a role:

2014-11-12 01:16:19,360 - INFO - POST request to /pulp/api/v2/roles/ with parameters {"display_name": null, "description": null, "role_id": "foo-role"}
2014-11-12 01:16:19,361 - INFO - Response status : 201

2014-11-12 01:16:19,361 - INFO - Response body :
{
"display_name": "foo-role",
"description": null,
"_ns": "roles",
"permissions": {},
"_id": {
"$oid": "5462b4e3d7a7470368373223"
},
"id": "foo-role",
"_href": "/pulp/api/v2/roles/foo-role/"
}

Assigning this to 3.0.0 since that is our next opportunity to fix this.

+ This comment was cloned from Bugzilla #1021962 comment 1 +

#3 Updated by amacdona@redhat.com almost 7 years ago

  • Platform Release deleted (3.0.0)

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#5 Updated by bmbouter over 2 years ago

  • Severity set to 1. Low

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#6 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#7 Updated by bmbouter over 1 year ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF