Project

Profile

Help

Story #3728

closed

Story #3716: As a production Pulp user, I have an Ansible installer

Story #3719: Create the webserver role

As a role user, I can have Apache installed and configured to serve Pulp

Added by bmbouter almost 6 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This should configure Apache to serve all Pulp wsgi applications to be served via /.

The documentation on how to deploy Pulp's webserver are here: https://docs.pulpproject.org/en/3.0/nightly/overview/components/webserver.html

It should install the systemd files for Apache.

Part of this story is to add variable(s) to the webserver role to indicate nginx or apache.


Related issues

Is duplicate of Pulp - Task #2921: Create and publish an ansible role to install apache and configure it for pulpCLOSED - WONTFIX

Actions
Actions #1

Updated by bmbouter almost 6 years ago

  • Parent issue changed from #3716 to #3719
Actions #2

Updated by amacdona@redhat.com almost 6 years ago

  • Is duplicate of Task #2921: Create and publish an ansible role to install apache and configure it for pulp added
Actions #3

Updated by amacdona@redhat.com almost 6 years ago

  • Status changed from NEW to CLOSED - WONTFIX

This story has been split, each of the new stories is marked as a duplicate.

Actions #4

Updated by amacdona@redhat.com almost 6 years ago

  • Status changed from CLOSED - WONTFIX to NEW
Actions #5

Updated by amacdona@redhat.com over 5 years ago

  • Description updated (diff)

Added by Eric D. Helms over 5 years ago

Revision f487f0bd | View on GitHub

Add Apache webserver support

Actions #6

Updated by amacdona@redhat.com over 5 years ago

  • Status changed from NEW to MODIFIED
  • Assignee set to ehelms@redhat.com
Actions #7

Updated by daviddavis almost 5 years ago

  • Sprint/Milestone set to 3.0.0
Actions #8

Updated by bmbouter almost 5 years ago

  • Tags deleted (Pulp 3)
Actions #9

Updated by bmbouter over 4 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
Actions #10

Updated by bmbouter almost 4 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)

Also available in: Atom PDF