Project

Profile

Help

Story #3724

As a role user, I can install a source version of pulpcore or pulpplugin

Added by bmbouter over 2 years ago. Updated 9 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The Ansible role will need to support installing one or more Python packages prior to the normal plugin installation. This will allow the user to install a source checkout of pulpcore and/or pulpcore.plugin. Here are the requirements:

pulpcore and/or pulpcore.plugin can be installed prior to any plugins by the user specifying options like:

  • django_app_label
  • editable
  • extra_args
  • name: # The name of a Python library to install or the url [or file path] of the package. As of 2.2 you can supply a list of names.

'name' can take on the following values:

  • VCS project url
  • Local path to project
  • Local or remote source archive

Related issues

Is duplicate of Pulp - Story #3971: As a pulp3 role user, I can install pulpcore from sourceCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com about 2 years ago

  • Related to Story #3971: As a pulp3 role user, I can install pulpcore from source added

#2 Updated by amacdona@redhat.com about 2 years ago

  • Related to deleted (Story #3971: As a pulp3 role user, I can install pulpcore from source)

#3 Updated by amacdona@redhat.com about 2 years ago

  • Is duplicate of Story #3971: As a pulp3 role user, I can install pulpcore from source added

#4 Updated by amacdona@redhat.com almost 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by daviddavis almost 2 years ago

  • Sprint/Milestone set to 3.0.0

#6 Updated by bmbouter almost 2 years ago

  • Tags deleted (Pulp 3)

#7 Updated by bmbouter 9 months ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF