Project

Profile

Help

Task #3718

Make all services installable via Ansible on one or more hosts

Added by bmbouter over 1 year ago. Updated 6 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 3 installer
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Ensure the role can install any of the following services on one or more hosts:
  • webserver
  • pulp_workers <------ how many?
  • resource manager
  • streamer+squid
  • Redis
  • Postgres

Without multiple roles, how do we have a subset of the processes run on multiple hosts?

History

#1 Updated by bmbouter over 1 year ago

I did think of a problem w/ this design. We need to ensure that each service (webserver+pulp, redis, postgresql, workers+pulp, resource_manager+pulp) can be installed on one or more hosts in the inventory. Typically this is done with ansible roles and the playbook says run roles ['a', 'b'] on host 1 and role 'c' on host 2. With everything being variables now this becomes something we have to handle and that is different from how Ansible normally works.

I think this means that we have to have multiple roles, with each thing that we may want to run on a separate host being in one role. Is there another option here?

#2 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Parent task deleted (#3716)

Closing as a duplicate of #3723

#3 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#4 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF