Project

Profile

Help

Issue #3709

pulp_resource_manager fails to start

Added by signed8bit over 2 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I have a fresh install of 2.16.1 I was testing. I created a repo successfully but when I tried to publish it I noticed that the pulp_resource_manager had crashed with the following error: celery.worker:CRITICAL: (865-25984) TypeError: 'NoneType' object is not callable

I have attached a log sample that was captured when attempting to start pulp_resource_manager.

pulp-log.txt (17.4 KB) pulp-log.txt pulp_resource_manger start error signed8bit, 05/30/2018 05:47 PM

History

#1 Updated by bmbouter over 2 years ago

Here is the exception from the logs that is causing the error:

pulp[21584]: celery.worker:CRITICAL: (21584-98112)     self._quick_put((TASK, (result._job, None, func, args, kwds)))
pulp[21584]: celery.worker:CRITICAL: (21584-98112) TypeError: 'NoneType' object is not callable

This means that self in self._quick_put is None. That suggests to me that this environmental somehow.

@signed8bit, how did you install it? Can you list your rpm packages and your "pip freeze" output?

#2 Updated by signed8bit over 2 years ago

I can't seem to reproduce this today. I just ran a fresh bringup of 2.16.1 with the same Ansible automation we always use and everything looks good. It certainly appears to have been a transient environment issue. Feel free close this out as not a bug.

#3 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - NOTABUG

Thanks @signed8bit. I'll close as NOTABUG for now. Please post or reopen if you see it again. Thanks!

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF