Project

Profile

Help

Issue #3688

Plugin PR unittester installs unittests from master, but code from PR

Added by bizhang over 3 years ago. Updated almost 3 years ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Plugin pr unittest jobs are failing when both code and unittest changes are present. Unittests are installed from the master branch, but the code is installed from the PR.

This was originally fixed by installing all packages into the same venv: https://github.com/pulp/pulp-ci/pull/516

But that caused some issues: https://pulp.plan.io/issues/3684

We need to fix the environment and stop installing packages to different venv/system python locations

[0] https://github.com/pulp/pulp_python/pull/174

History

#1 Updated by bizhang over 3 years ago

  • Status changed from NEW to CLOSED - WORKSFORME

I am not able to reproduce this on https://github.com/pulp/pulp_python/pull/174
Closing this, we can reopen if the issue ever occurs again

#2 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF