Project

Profile

Help

Story #3548

r10k doesn't work with pulp_puppet

Added by dhollinger over 3 years ago. Updated 10 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The Puppet module deployment tool, r10k, no longer works with Pulp puppet module repositories.

r10k, and by extension the Puppet Enterprise Code Manager tool, expect the existence of the /modules endpoints from the Forge API to be implemented. It uses the /modules endpoint to find and pull the module(s) down from a Forge (internal or external).

Examples:
r10k deploy module command:

[root@dev-puppetserver ~]# r10k deploy module rsyslog -e development -v
INFO     -> Deploying module /etc/puppetlabs/code-staging/environments/development/modules/rsyslog
ERROR     -> The module puppet-rsyslog does not exist on http://pulp01.example.net/.

Pulp Access Log:

172.16.8.29 - - [04/Apr/2018:11:52:14 -0500] "GET /v3/modules/puppet-rsyslog HTTP/1.1" 404 99 "-" "PuppetForge.gem/2.2.9 Faraday/0.9.2 Ruby/2.4.3-p205 (x86_64-linux)"

curl results from the /releases endpoint:

[root@puppetserver ~]# curl -s -XGET http://.:1-Puppet_Modules-Library-puppet-040e1e45-5c41-4247-abe4-d9aeda5e3353@pulp01.example.net/v3/releases/puppet-rsyslog-3.1.1 | jq
{
  "file_uri": "/pulp/puppet/1-Puppet_Modules-Library-puppet-040e1e45-5c41-4247-abe4-d9aeda5e3353/system/releases/p/puppet/puppet-rsyslog-3.1.1.tar.gz",
  "file_md5": "4148537e16a21f5ab1283d324eca24fb",
  "metadata": {
    "version": "3.1.1",
    "name": "puppet/rsyslog",
    "dependencies": [
      {
        "name": "puppetlabs-stdlib",
        "version_requirement": ">= 1.0.0 < 5.0.0"
      },
      {
        "name": "puppetlabs-concat",
        "version_requirement": ">= 2.0.0 < 5.0.0"
      }
    ]
  }
}

We need the /modules endpoint implemented in pulp_puppet to maintain compatibility with r10k and reliant tools


Related issues

Is duplicate of Puppet Support - Story #1848: As a user I would like support for the `v3/modules` API endpoint, used by librarian-puppet.CLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dhollinger over 3 years ago

After some additional discussions with the Puppet Community. It looks like R10K requires both the /releases and /modules endpoints. It uses the /modules endpoints to find/verify a release is available (even when that release is hard-coded), then uses the /releases endpoint to pull the module down.

#2 Updated by dalley over 3 years ago

  • Tracker changed from Issue to Story
  • Project changed from Pulp to Puppet Support
  • Subject changed from r10k doesn't work with puppet_pulp to r10k doesn't work with pulp_puppet
  • Category deleted (14)
  • % Done set to 0

#3 Updated by dalley over 3 years ago

  • Is duplicate of Story #1848: As a user I would like support for the `v3/modules` API endpoint, used by librarian-puppet. added

#4 Updated by dalley over 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF