Project

Profile

Help

Maintenance. Planio will be undergoing a scheduled maintenance this weekend. Between Saturday, July 24 at 9:00 UTC and Sunday, July 25, 22:00 UTC your account might observe occasional downtimes which may last up to several minutes in some cases.

Issue #353

yum importer needs better reporting

Added by mhrivnak over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.2
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The current client-side reporting doesn't work very well. Many error conditions result in unfriendly behavior in the client and a failure to even deliver an error message.

+ This bug was cloned from Bugzilla Bug #971546 +

History

#1 Updated by mhrivnak over 6 years ago

https://github.com/pulp/pulp_rpm/pull/233

I'm leaving this bug as "assigned" unless there are objections, because there may still be more work to do on it. I don't have time at the moment to do a good analysis of what else should be improved.

+ This comment was cloned from Bugzilla #971546 comment 1 +

#2 Updated by mhrivnak over 6 years ago

***** Bug 887039 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #971546 comment 2 +

#3 Updated by bcourt over 6 years ago

Should we use this bug to convert the yum importer to use the step framework?

#4 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#5 Updated by bmbouter over 5 years ago

mhrivnak, do you have an example of one of these errors that doesn't make it client side? I'm trying to make this more actionable.

#6 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#7 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF