Project

Profile

Help

Issue #338

ISE when descritpion or display-name has i18n characters on repo create

Added by pthomas@redhat.com about 5 years ago. Updated about 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Master
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Description of problem:
ISE when repo create is run with i18n characters for --display-name or description

Version-Release number of selected component (if applicable):

pulp-rpm-server-0.0.307-1.el6.noarch
pulp-rpm-admin-client-0.0.307-1.el6.noarch

How reproducible:

Steps to Reproduce:
1. pulp-admin -u admin -p admin repo create --repo-id pulp1 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display-Brasília " --description "pulp repo desc"
2.
3.

Actual results:
[root@preethi-el6-pulp ~]# pulp-admin -u admin -p admin repo create --repo-id pulp1 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display-Brasília " --description "pulp repo desc"
An internal error occurred on the Pulp server. More information can be found in
the client log file ~/.pulp/admin.log.

[root@preethi-el6-pulp ~]# pulp-admin -u admin -p admin repo create --repo-id pulp2 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display" --description "pulp repo desc-Brasília" An internal error occurred on the Pulp server. More information can be found in
the client log file ~/.pulp/admin.log.

Expected results:

Additional info:

2012-06-27 11:36:07,928 16671:140082841384704: pulp.server.webservices.middleware.exception:ERROR: exception:62 Unhandled Exception
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in call
return self.app(environ, start_response)
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 38, in call
return self.app(environ, start_response)
File "/usr/lib/python2.6/site-packages/web/application.py", line 278, in wsgi
result = self.handle_with_processors()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in _handle_with_processors
return process(self.processors)
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
return handler()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
result = handler()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 27, in process
return self.handle()
File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
return self._delegate(fn, self.fvars, args)
File "/usr/lib/python2.6/site-packages/web/application.py", line 413, in _delegate
return f()
File "/usr/lib/python2.6/site-packages/web/application.py", line 421, in <lambda>
f = lambda: self._delegate_sub_application(pat, what)
File "/usr/lib/python2.6/site-packages/web/application.py", line 446, in _delegate_sub_application
return app.handle_with_processors()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in _handle_with_processors
return process(self.processors)
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
return handler()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
result = handler()
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
return p(lambda : process(processors))
File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 27, in process
return self.handle()
File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
return self._delegate(fn, self.fvars, args)
File "/usr/lib/python2.6/site-packages/web/application.py", line 411, in _delegate
return handle_class(cls)

+ This bug was cloned from Bugzilla Bug #835951 +

History

#1 Updated by jconnor@redhat.com about 5 years ago

It turns out that the display_name is arriving on the server as a 'latin-1' encoded string and mongo is barfing when we try to store it in the database as part of the arguments to the create_repo call_request.

+ This comment was cloned from Bugzilla #835951 comment 1 +

#2 Updated by bmbouter about 5 years ago

  • Severity changed from Medium to 2. Medium

#3 Updated by fdobrovo almost 4 years ago

  • Status changed from NEW to ASSIGNED

#4 Updated by fdobrovo almost 4 years ago

  • Status changed from ASSIGNED to NEW

#5 Updated by bmbouter about 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#6 Updated by bmbouter about 1 year ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#7 Updated by bmbouter about 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF