Project

Profile

Help

Issue #330

Pulp packages are missing documentation

Added by slukasik@redhat.com almost 7 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

Version-Release number of selected component (if applicable):
pulp-client-0.0.206-1.fc14.noarch
pulp-common-0.0.206-1.fc14.noarch
pulp-cds-0.0.206-1.fc14.noarch
pulp-0.0.206-1.fc14.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. rpm -qld pulp-client pulp-common pulp-cds pulp
2.
3.

Actual results:
None

Expected results:
readme files and man pages

Additional info:

+ This bug was cloned from Bugzilla Bug #721314 +

History

#1 Updated by skarmark@redhat.com almost 7 years ago

We currently do not have man pages for pulp and there is an RFE open for that.

+ This comment was cloned from Bugzilla #721314 comment 1 +

#2 Updated by jason.dobies@redhat.com almost 7 years ago

Closing out as not a bug. It's not that they aren't included, it's that they aren't written yet :) We'll be adding them as a separate RFE.

+ This comment was cloned from Bugzilla #721314 comment 2 +

#3 Updated by slukasik@redhat.com almost 7 years ago

(In reply to comment #2)

Closing out as not a bug. It's not that they aren't included, it's that they
aren't written yet :)

This is not a fun. It is actually the reason why this ticket exists.

We'll be adding them as a separate RFE.

I don't want to see any bug being closed without resolution
or link to another tracking ticket.

+ This comment was cloned from Bugzilla #721314 comment 3 +

#4 Updated by mhrivnak almost 7 years ago

http://www.pulpproject.org/docs/

https://github.com/pulp/pulp/pull/638

That's a start, but we still don't have man pages.

+ This comment was cloned from Bugzilla #721314 comment 4 +

#5 Updated by mhrivnak almost 7 years ago

***** Bug 1010214 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #721314 comment 5 +

#7 Updated by slukasik@redhat.com almost 7 years ago

Oh my!

Thank You very much, sir!

+ This comment was cloned from Bugzilla #721314 comment 7 +

#8 Updated by cduryee almost 7 years ago

No problem:)

Merged to 2.6-dev and master

+ This comment was cloned from Bugzilla #721314 comment 8 +

#9 Updated by cduryee almost 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #721314 comment 9 +

#10 Updated by igulina@redhat.com almost 7 years ago

rpm -qa pulp-server

pulp-server-2.6.0-0.2.beta.el6.noarch

man pulp-admin | head -n 15

PULP-ADMIN (1) Pulp Project PULP-ADMIN (1)

NAME
pulp-admin - Pulp Documentation

Contents:

INTRODUCTION
The admin client is used to remotely manage a Pulp server. This client
is used to manage the operation of the server itself as well as trigger
remote operations on registered consumers.

For more information on the client that runs on Pulp consumers, see the

man pulp-consumer | head -n 15

PULP-CONSUMER (1) Pulp Project PULP-CONSUMER (1)

NAME
pulp-consumer - Pulp Documentation

Contents:

INTRODUCING THE PULP CONSUMER CLIENT
The Pulp consumer client, pulp-consumer, is a command line tool that
allows administrators to register a consumer, bind that consumer to
Pulp managed repositories, and install content onto the consumer from
those bound repositories.

+ This comment was cloned from Bugzilla #721314 comment 10 +

#11 Updated by bmbouter over 6 years ago

  • Severity set to 1. Low
  • Tags deleted (Reopened)

#12 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#14 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#15 Updated by vonrueden over 1 year ago

has it been solved? even though it was cloned from Bugzilla Bug #721314

Please register to edit this issue

Also available in: Atom PDF