Project

Profile

Help

Issue #3094

Unable to cancel pending unstarted tasks

Added by Anonymous about 3 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
4. Urgent
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

1. Created Consumers
2. Created Consumer Groups for Patching
3. Deleted some Consumers
4. Run Patching on the Consumer Group
5. Orphan Tasks that cannot be deleted

pulp-admin tasks cancel --task-id <task-id>

The following resources(s) could not be found

<consumer.hostname> (consumer)

Is there a workaround for this kind of issue?

History

#1 Updated by daviddavis about 3 years ago

I think this is a dupe of #3095 and can be closed out as such.

#2 Updated by mihai.ibanescu@gmail.com about 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by Luis Mayorga (luismayorga1980@gmail.com) about 3 years ago

Maybe another if statement for incomplete states?

https://github.com/pulp/pulp/blob/94b6161ddc870ea9dc7086b26dc01ca89c57205a/server/pulp/server/async/tasks.py#L645-L672

On 10/24/2017 12:54 PM, Pulp wrote:

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF