Project

Profile

Help

Task #3088

Add/update Workers Filters

Added by amacdona@redhat.com over 3 years ago. Updated almost 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This task should be marked "groomed" when both questions are answered.

1) What are the filtering use cases for this viewset?

2) What filters (field and FilterSet) should this viewset include?

3) Will the default viewset include both online and offline workers?

https://django-filter.readthedocs.io/en/latest/ref/filters.html#filters


Related issues

Is duplicate of Pulp - Story #3143: As an authenticated user, I can filter workers.CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Copied from Pulp - Task #3087: Add/update Users FiltersCLOSED - COMPLETE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com over 3 years ago

  • Copied from Task #3087: Add/update Users Filters added

#2 Updated by bmbouter about 3 years ago

  • Description updated (diff)

I think this viewset should show all workers both online and offline. The status API only includes online workers because its intent is to help the user reason about the current state of their Pulp installation.

Here are the possible use cases I can think of:

As a user, I can filter by the value of the 'online' (boolean)

As a user, I can filter with lt, gt, eq on the 'heartbeat' timestamp

As a user, I can filter by 'name' with explicit matching so that I can monitor a single worker by name.
As a user, I can filter by 'name' with substring matching so that I can monitor a group of workers on a single machine, or data center

#3 Updated by daviddavis about 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3143 has the groomed user stories and fields. Closing in favor of #3143.

#4 Updated by daviddavis about 3 years ago

  • Is duplicate of Story #3143: As an authenticated user, I can filter workers. added

#5 Updated by daviddavis almost 2 years ago

  • Sprint/Milestone set to 3.0.0

#6 Updated by bmbouter almost 2 years ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF