Project

Profile

Help

Story #2980

closed

As QE I would like to have md5 checksums of docker_image, docker_blob units for correlation with other tools using md5

Added by rmcgover almost 7 years ago. Updated about 5 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Target Release - Docker:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

For content of type docker_image and docker_blob, it would be useful for us to have MD5 checksums generated on import and available on the unit thereafter, so that we can check consistency of shipped content in conjunction with tools only supporting MD5.

Here are some more details about the use-case:

- We use pulp_docker to manage docker content for publish.
- We (will) use docker_rsync_distributor to publish docker content to a remote CDN.
- We want to implement a consistency check to verify that data on our CDN is identical to the source data in Pulp (e.g. has not been corrupted after or during publish).
- Our CDN provides a lightweight method to fetch the checksum of a file without downloading it (as an HTTP header), but this only supports MD5.

The CDN is a third-party service and it might be impractical to have that improved with support for other checksum types such as SHA256.

Having the MD5 checksums would allow us to implement consistency checks which compare the checksum reported by our CDN to the checksum stored in Pulp.


Related issues

Is duplicate of Docker Support - Story #3137: As a user, I can view docker image Arch and Size Information through the REST APICLOSED - CURRENTRELEASEbizhang

Actions
Actions #2

Updated by dkliban@redhat.com almost 6 years ago

  • Is duplicate of Story #3137: As a user, I can view docker image Arch and Size Information through the REST API added
Actions #3

Updated by dkliban@redhat.com almost 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #4

Updated by bmbouter about 5 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF