Project

Profile

Help

Task #2879

Create a 'pulp' user for Pulp3 in the development environment

Added by bizhang about 3 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Dev Environment
Sprint:
Quarter:

Description

Problem:

In Pulp2 /var/lib/pulp was owned by the apache user. For Pulp3 we do not want to be limited to apache as the server thus having an 'apache' user own the directory and our processes makes little sense.

Note: This ticket is for the developer environment only. Changes to a production Pulp environment are being tracked in part as issue #2840.

Solution

Our Pulp devel environment should create a pulp user to own /var/lib/pulp and the running celery processes.

vagrant ssh should switch to using the 'pulp' user automatically by configuring the Vagrantfile with config.ssh.username.


Checklist


Related issues

Is duplicate of Pulp - Issue #3050: get rid of "apache" user in dev environmentCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter about 3 years ago

  • Subject changed from Create a pulp user for Pulp3 to Create a 'pulp' user for Pulp3
  • Description updated (diff)
  • Tags Dev Environment added

Adding checklist items and some small rewrites.

#2 Updated by mhrivnak about 3 years ago

We should also have the supplied apache config file run any WSGI processes as the pulp user.

#3 Updated by bizhang about 3 years ago

  • Description updated (diff)

#4 Updated by mhrivnak about 3 years ago

Is this scoped only to the development environment? The solution reads that way, but the title and problem does not.

Maybe that's just because we can't do anything else right now. What actions do we need to take for this to apply also to production deployment? Maybe all we can do at this point is create one or more tasks to do this when we get around to RPM packaging, add documentation, etc?

#5 Updated by bmbouter about 3 years ago

mhrivnak wrote:

We should also have the supplied apache config file run any WSGI processes as the pulp user.

This ticket is for making improvements to the dev environment which probably won't get Apache any time soon. We need to have the WSGI processes run as the Pulp user configured as part of the production Ansible work which can be done right after #2840 and when the configs are available.

#6 Updated by bizhang about 3 years ago

  • Tags Pulp 3 Plugin Writer Alpha added
  • Tags deleted (Dev Environment)

#7 Updated by bmbouter about 3 years ago

  • Subject changed from Create a 'pulp' user for Pulp3 to Create a 'pulp' user for Pulp3 in the development environment
  • Description updated (diff)
  • Tags Dev Environment added

#8 Updated by mhrivnak about 3 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#9 Updated by bizhang about 3 years ago

  • Tags deleted (Pulp 3 Plugin Writer Alpha)

#10 Updated by dalley almost 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Duplicate of 3050 which has already been assigned

https://pulp.plan.io/issues/3050

#11 Updated by bmbouter almost 3 years ago

  • Is duplicate of Issue #3050: get rid of "apache" user in dev environment added

#12 Updated by daviddavis over 1 year ago

  • Sprint/Milestone set to 3.0.0

#13 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF