Project

Profile

Help

Story #286

Pulp clients should not log to files

Added by rbarlow almost 7 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1175820 ++

Description of problem:

Description of problem:
pulp-admin and pulp-consumer log to files by default. This can cause concurrency issues if users run more than one command at a time. It's also inconvenient when there is an error, as the CLI tells the user "there was a problem, see the log" instead of just showing the user the error.

Most CLI programs offer -v and -vv flags. I propose that we do the same. The -v flag would cause all things that go to admin.log to go to the console. The -vv flag would do the same and also add in the server_calls.log. If the user wants these to go to files, they can use standard Unix shell redirection to accomplish that.

One exception is Exceptions ☺ We should print unexpected exceptions to the screen even in normal mode.

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Every time.

Steps to Reproduce:
1. Do pulp-admin and pulp-consumer log to files?
2. Can you adjust the console verbosity?

Actual results:
No and no.

Expected results:
Yes and yes.


Related issues

Is duplicate of Pulp - Story #145: As a pulp-admin user, I would like logs to go to stderrCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter over 6 years ago

  • Is duplicate of Story #145: As a pulp-admin user, I would like logs to go to stderr added

#2 Updated by bmbouter over 6 years ago

  • Subject changed from [RFE] Pulp clients should not log to files to Pulp clients should not log to files
  • Status changed from ASSIGNED to 7

#3 Updated by bmbouter over 6 years ago

  • Status changed from 7 to CLOSED - DUPLICATE

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF