Project

Profile

Help

Issue #2600

2.12.1 beta failing to install due to dependency issue

Added by pthomas@redhat.com about 2 years ago. Updated 5 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Severity:
2. Medium
Version:
2.12.1
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
Yes
Verification Required:
No
Sprint:

Description


[root@qe-blade-13 yum.repos.d]# sudo yum install pulp-server python-gofer-qpid python-qpid qpid-tools
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package pulp-server.noarch 0:2.12.1-0.1.beta.el7 will be installed
--> Processing Dependency: python-pulp-repoauth = 2.12.1 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-pulp-common = 2.12.1 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-celery < 3.2.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-semantic_version >= 2.2.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-pymongo >= 3.0.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-oauth2 >= 1.5.211 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-nectar >= 1.5.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-mongoengine >= 0.10.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-django >= 1.4.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-celery >= 3.1.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: mod_xsendfile >= 0.12 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: mod_wsgi >= 3.4-1.pulp for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-ldap for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-httplib2 for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: python-blinker for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: pulp-selinux for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: mod_ssl for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: kobo for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: httpd for package: pulp-server-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: genisoimage for package: pulp-server-2.12.1-0.1.beta.el7.noarch
---> Package python-gofer-qpid.noarch 0:2.7.6-1.el7 will be installed
---> Package python-qpid.noarch 0:1.35.0-1.el7 will be installed
--> Processing Dependency: python-qpid-common = 1.35.0-1.el7 for package: python-qpid-1.35.0-1.el7.noarch
--> Processing Dependency: python-saslwrapper for package: python-qpid-1.35.0-1.el7.noarch
---> Package qpid-tools.noarch 0:1.35.0-1.el7 will be installed
--> Processing Dependency: python-qpid-qmf for package: qpid-tools-1.35.0-1.el7.noarch
--> Running transaction check
---> Package genisoimage.x86_64 0:1.1.11-23.el7 will be installed
--> Processing Dependency: libusal = 1.1.11-23.el7 for package: genisoimage-1.1.11-23.el7.x86_64
--> Processing Dependency: librols.so.0()(64bit) for package: genisoimage-1.1.11-23.el7.x86_64
--> Processing Dependency: libusal.so.0()(64bit) for package: genisoimage-1.1.11-23.el7.x86_64
---> Package httpd.x86_64 0:2.4.6-45.el7 will be installed
--> Processing Dependency: httpd-tools = 2.4.6-45.el7 for package: httpd-2.4.6-45.el7.x86_64
---> Package kobo.noarch 0:0.5.1-1.el7 will be installed
---> Package mod_ssl.x86_64 1:2.4.6-45.el7 will be installed
---> Package mod_wsgi.x86_64 0:3.4-12.el7_0 will be installed
---> Package mod_xsendfile.x86_64 0:0.12-10.el7 will be installed
---> Package pulp-selinux.noarch 0:2.12.1-0.1.beta.el7 will be installed
--> Processing Dependency: policycoreutils-python for package: pulp-selinux-2.12.1-0.1.beta.el7.noarch
--> Processing Dependency: /usr/sbin/semanage for package: pulp-selinux-2.12.1-0.1.beta.el7.noarch
---> Package python-blinker.noarch 0:1.3-2.el7 will be installed
---> Package python-celery.noarch 0:3.1.11-1.el7 will be installed
--> Processing Dependency: python-kombu >= 3.0.15 for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-billiard >= 3.3.0.17 for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: pytz for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-anyjson for package: python-celery-3.1.11-1.el7.noarch
--> Processing Dependency: python-amqp for package: python-celery-3.1.11-1.el7.noarch
---> Package python-django.noarch 0:1.6.11-5.el7 will be installed
--> Processing Dependency: python-django-bash-completion = 1.6.11-5.el7 for package: python-django-1.6.11-5.el7.noarch
---> Package python-gofer.noarch 0:2.7.6-1.el7 will be installed
---> Package python-httplib2.noarch 0:0.7.7-3.el7 will be installed
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el7 will be installed
---> Package python-ldap.x86_64 0:2.4.15-2.el7 will be installed
---> Package python-mongoengine.noarch 0:0.10.5-1.el7 will be installed
--> Processing Dependency: python-pymongo-gridfs >= 3.2 for package: python-mongoengine-0.10.5-1.el7.noarch
---> Package python-nectar.noarch 0:1.5.3-1.el7 will be installed
--> Processing Dependency: python-requests >= 2.4.3 for package: python-nectar-1.5.3-1.el7.noarch
---> Package python-oauth2.noarch 0:1.5.211-8.el7 will be installed
--> Processing Dependency: python-simplejson for package: python-oauth2-1.5.211-8.el7.noarch
---> Package python-pulp-common.noarch 0:2.12.1-0.1.beta.el7 will be installed
---> Package python-pulp-repoauth.noarch 0:2.12.1-0.1.beta.el7 will be installed
---> Package python-pymongo.x86_64 0:3.2-1.el7 will be installed
--> Processing Dependency: python-bson = 3.2-1.el7 for package: python-pymongo-3.2-1.el7.x86_64
---> Package python-qpid-common.noarch 0:1.35.0-1.el7 will be installed
---> Package python-qpid-qmf.x86_64 0:1.35.0-1.el7 will be installed
--> Processing Dependency: qpid-qmf(x86-64) = 1.35.0-1.el7 for package: python-qpid-qmf-1.35.0-1.el7.x86_64
--> Processing Dependency: libqmf2.so.1()(64bit) for package: python-qpid-qmf-1.35.0-1.el7.x86_64
---> Package python-saslwrapper.x86_64 0:0.16-5.el7 will be installed
--> Processing Dependency: saslwrapper(x86-64) = 0.16-5.el7 for package: python-saslwrapper-0.16-5.el7.x86_64
--> Processing Dependency: libsaslwrapper.so.1()(64bit) for package: python-saslwrapper-0.16-5.el7.x86_64
---> Package python-semantic_version.noarch 0:2.4.2-1.el7 will be installed
--> Running transaction check
---> Package httpd-tools.x86_64 0:2.4.6-45.el7 will be installed
---> Package libusal.x86_64 0:1.1.11-23.el7 will be installed
---> Package policycoreutils-python.x86_64 0:2.5-11.el7_3 will be installed
--> Processing Dependency: policycoreutils = 2.5-11.el7_3 for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libsemanage-python >= 2.5-5 for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64
---> Package python-amqp.noarch 0:1.4.9-1.el7 will be installed
---> Package python-anyjson.noarch 0:0.3.3-3.el7 will be installed
---> Package python-billiard.x86_64 1:3.3.0.20-2.el7 will be installed
---> Package python-bson.x86_64 0:3.2-1.el7 will be installed
---> Package python-django-bash-completion.noarch 0:1.6.11-5.el7 will be installed
---> Package python-kombu.noarch 1:3.0.33-6.pulp.el7 will be installed
---> Package python-pymongo-gridfs.x86_64 0:3.2-1.el7 will be installed
---> Package python-requests.noarch 0:2.6.0-1.el7_1 will be installed
--> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-1.el7_1.noarch
---> Package python2-simplejson.x86_64 0:3.10.0-1.el7 will be installed
---> Package pytz.noarch 0:2012d-5.el7 will be installed
---> Package qpid-qmf.x86_64 0:1.35.0-1.el7 will be installed
---> Package saslwrapper.x86_64 0:0.16-5.el7 will be installed
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.6.5-3.el7 will be installed
---> Package checkpolicy.x86_64 0:2.5-4.el7 will be installed
---> Package libcgroup.x86_64 0:0.41-11.el7 will be installed
---> Package libsemanage-python.x86_64 0:2.5-5.1.el7_3 will be installed
--> Processing Dependency: libsemanage = 2.5-5.1.el7_3 for package: libsemanage-python-2.5-5.1.el7_3.x86_64
---> Package policycoreutils.x86_64 0:2.5-8.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-11.el7_3 will be an update
---> Package python-IPy.noarch 0:0.75-6.el7 will be installed
---> Package python-urllib3.noarch 0:1.10.2-2.el7_1 will be installed
--> Processing Dependency: python-six for package: python-urllib3-1.10.2-2.el7_1.noarch
---> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be installed
--> Running transaction check
---> Package libsemanage.x86_64 0:2.5-4.el7 will be updated
---> Package libsemanage.x86_64 0:2.5-5.1.el7_3 will be an update
---> Package python-six.noarch 0:1.9.0-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================
 Package                       Arch   Version                Repository                 Size
=============================================================================================
Installing:
 pulp-server                   noarch 2.12.1-0.1.beta.el7    pulp-2.12-beta            763 k
 python-gofer-qpid             noarch 2.7.6-1.el7            pulp-2.12-beta             53 k
 python-qpid                   noarch 1.35.0-1.el7           epel                       94 k
 qpid-tools                    noarch 1.35.0-1.el7           epel                      144 k
Installing for dependencies:
 audit-libs-python             x86_64 2.6.5-3.el7            beaker-Server              70 k
 checkpolicy                   x86_64 2.5-4.el7              beaker-Server             290 k
 genisoimage                   x86_64 1.1.11-23.el7          beaker-Server             298 k
 httpd                         x86_64 2.4.6-45.el7           beaker-Server             1.2 M
 httpd-tools                   x86_64 2.4.6-45.el7           beaker-Server              84 k
 kobo                          noarch 0.5.1-1.el7            epel                      100 k
 libcgroup                     x86_64 0.41-11.el7            beaker-Server              65 k
 libsemanage-python            x86_64 2.5-5.1.el7_3          rhel-7-server-rpms        104 k
 libusal                       x86_64 1.1.11-23.el7          beaker-Server             135 k
 mod_ssl                       x86_64 1:2.4.6-45.el7         beaker-Server             105 k
 mod_wsgi                      x86_64 3.4-12.el7_0           beaker-Server              76 k
 mod_xsendfile                 x86_64 0.12-10.el7            epel                       16 k
 policycoreutils-python        x86_64 2.5-11.el7_3           rhel-7-server-rpms        445 k
 pulp-selinux                  noarch 2.12.1-0.1.beta.el7    pulp-2.12-beta             79 k
 python-IPy                    noarch 0.75-6.el7             beaker-Server              32 k
 python-amqp                   noarch 1.4.9-1.el7            pulp-2.12-beta             87 k
 python-anyjson                noarch 0.3.3-3.el7            epel                       13 k
 python-billiard               x86_64 1:3.3.0.20-2.el7       epel                      173 k
 python-blinker                noarch 1.3-2.el7              rhel-7-server-extras-rpms  93 k
 python-bson                   x86_64 3.2-1.el7              pulp-2.12-beta            192 k
 python-celery                 noarch 3.1.11-1.el7           pulp-2.12-beta            1.8 M
 python-django                 noarch 1.6.11-5.el7           epel                      4.0 M
 python-django-bash-completion noarch 1.6.11-5.el7           epel                       16 k
 python-gofer                  noarch 2.7.6-1.el7            pulp-2.12-beta            132 k
 python-httplib2               noarch 0.7.7-3.el7            epel                       70 k
 python-isodate                noarch 0.5.0-4.pulp.el7       pulp-2.12-beta             50 k
 python-kombu                  noarch 1:3.0.33-6.pulp.el7    pulp-2.12-beta            486 k
 python-ldap                   x86_64 2.4.15-2.el7           beaker-Server             159 k
 python-mongoengine            noarch 0.10.5-1.el7           pulp-2.12-beta            407 k
 python-nectar                 noarch 1.5.3-1.el7            pulp-2.12-beta             47 k
 python-oauth2                 noarch 1.5.211-8.el7          epel                       28 k
 python-pulp-common            noarch 2.12.1-0.1.beta.el7    pulp-2.12-beta            123 k
 python-pulp-repoauth          noarch 2.12.1-0.1.beta.el7    pulp-2.12-beta             77 k
 python-pymongo                x86_64 3.2-1.el7              pulp-2.12-beta            349 k
 python-pymongo-gridfs         x86_64 3.2-1.el7              pulp-2.12-beta            146 k
 python-qpid-common            noarch 1.35.0-1.el7           epel                      286 k
 python-qpid-qmf               x86_64 1.35.0-1.el7           epel                      170 k
 python-requests               noarch 2.6.0-1.el7_1          beaker-Server              93 k
 python-saslwrapper            x86_64 0.16-5.el7             epel                       26 k
 python-semantic_version       noarch 2.4.2-1.el7            epel                       23 k
 python-six                    noarch 1.9.0-2.el7            beaker-Server              29 k
 python-urllib3                noarch 1.10.2-2.el7_1         beaker-Server             100 k
 python2-simplejson            x86_64 3.10.0-1.el7           epel                      188 k
 pytz                          noarch 2012d-5.el7            beaker-Server              38 k
 qpid-qmf                      x86_64 1.35.0-1.el7           epel                      160 k
 saslwrapper                   x86_64 0.16-5.el7             epel                       19 k
 setools-libs                  x86_64 3.3.8-1.1.el7          beaker-Server             610 k
Updating for dependencies:
 libsemanage                   x86_64 2.5-5.1.el7_3          rhel-7-server-rpms        145 k
 policycoreutils               x86_64 2.5-11.el7_3           rhel-7-server-rpms        842 k

Transaction Summary
=============================================================================================
Install  4 Packages (+47 Dependent packages)
Upgrade             (  2 Dependent packages)

Total download size: 15 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/53): audit-libs-python-2.6.5-3.el7.x86_64.rpm                      |  70 kB  00:00:00     
(2/53): genisoimage-1.1.11-23.el7.x86_64.rpm                          | 298 kB  00:00:00     
(3/53): checkpolicy-2.5-4.el7.x86_64.rpm                              | 290 kB  00:00:00     
(4/53): httpd-tools-2.4.6-45.el7.x86_64.rpm                           |  84 kB  00:00:00     
(5/53): libcgroup-0.41-11.el7.x86_64.rpm                              |  65 kB  00:00:00     
(6/53): httpd-2.4.6-45.el7.x86_64.rpm                                 | 1.2 MB  00:00:00     
(7/53): libusal-1.1.11-23.el7.x86_64.rpm                              | 135 kB  00:00:00     
(8/53): mod_ssl-2.4.6-45.el7.x86_64.rpm                               | 105 kB  00:00:00     
(9/53): mod_wsgi-3.4-12.el7_0.x86_64.rpm                              |  76 kB  00:00:00     
(10/53): kobo-0.5.1-1.el7.noarch.rpm                                  | 100 kB  00:00:00     
warning: /var/cache/yum/x86_64/7Server/rhel-7-server-rpms/packages/libsemanage-2.5-5.1.el7_3.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
Public key for libsemanage-2.5-5.1.el7_3.x86_64.rpm is not installed
(11/53): libsemanage-2.5-5.1.el7_3.x86_64.rpm                         | 145 kB  00:00:00     
(12/53): libsemanage-python-2.5-5.1.el7_3.x86_64.rpm                  | 104 kB  00:00:00     
(13/53): policycoreutils-2.5-11.el7_3.x86_64.rpm                      | 842 kB  00:00:00     
(14/53): python-IPy-0.75-6.el7.noarch.rpm                             |  32 kB  00:00:00     
(15/53): policycoreutils-python-2.5-11.el7_3.x86_64.rpm               | 445 kB  00:00:00     
warning: /var/cache/yum/x86_64/7Server/pulp-2.12-beta/packages/pulp-selinux-2.12.1-0.1.beta.el7.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2c7e5d9a: NOKEY
Public key for pulp-selinux-2.12.1-0.1.beta.el7.noarch.rpm is not installed
(16/53): pulp-selinux-2.12.1-0.1.beta.el7.noarch.rpm                  |  79 kB  00:00:00     
(17/53): python-anyjson-0.3.3-3.el7.noarch.rpm                        |  13 kB  00:00:00     
python-amqp-1.4.9-1.el7.noarch FAILED                                           00:00:25 ETA 
https://repos.fedorapeople.org/repos/pulp/pulp/beta/2.12/7Server/x86_64/python-amqp-1.4.9-1.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=pulp-2.12-beta clean metadata
Trying other mirror.
Public key for python-blinker-1.3-2.el7.noarch.rpm is not installed/s | 4.2 MB  00:00:24 ETA 
(18/53): python-blinker-1.3-2.el7.noarch.rpm                          |  93 kB  00:00:00     
(19/53): python-bson-3.2-1.el7.x86_64.rpm                             | 192 kB  00:00:00     
(20/53): pulp-server-2.12.1-0.1.beta.el7.noarch.rpm                   | 763 kB  00:00:02     
(21/53): python-django-1.6.11-5.el7.noarch.rpm                        | 4.0 MB  00:00:00     
(22/53): python-django-bash-completion-1.6.11-5.el7.noarch.rpm        |  16 kB  00:00:00     
(23/53): python-gofer-2.7.6-1.el7.noarch.rpm                          | 132 kB  00:00:00     
(24/53): python-httplib2-0.7.7-3.el7.noarch.rpm                       |  70 kB  00:00:00     
(25/53): python-gofer-qpid-2.7.6-1.el7.noarch.rpm                     |  53 kB  00:00:00     
(26/53): python-isodate-0.5.0-4.pulp.el7.noarch.rpm                   |  50 kB  00:00:00     
(27/53): python-ldap-2.4.15-2.el7.x86_64.rpm                          | 159 kB  00:00:00     
python-celery-3.1.11-1.el7.noa FAILED                                           00:00:02 ETA 
https://repos.fedorapeople.org/repos/pulp/pulp/beta/2.12/7Server/x86_64/python-celery-3.1.11-1.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=pulp-2.12-beta clean metadata
Trying other mirror.
(28/53): python-kombu-3.0.33-6.pulp.el7.noarch.rpm                    | 486 kB  00:00:00     
(29/53): python-mongoengine-0.10.5-1.el7.noarch.rpm                   | 407 kB  00:00:00     
(30/53): python-nectar-1.5.3-1.el7.noarch.rpm                         |  47 kB  00:00:00     
(31/53): python-oauth2-1.5.211-8.el7.noarch.rpm                       |  28 kB  00:00:00     
(32/53): python-pulp-common-2.12.1-0.1.beta.el7.noarch.rpm            | 123 kB  00:00:00     
(33/53): python-pulp-repoauth-2.12.1-0.1.beta.el7.noarch.rpm          |  77 kB  00:00:00     
(34/53): python-qpid-1.35.0-1.el7.noarch.rpm                          |  94 kB  00:00:00     
(35/53): python-pymongo-gridfs-3.2-1.el7.x86_64.rpm                   | 146 kB  00:00:00     
(36/53): python-pymongo-3.2-1.el7.x86_64.rpm                          | 349 kB  00:00:00     
(37/53): python-qpid-common-1.35.0-1.el7.noarch.rpm                   | 286 kB  00:00:00     
(38/53): python-requests-2.6.0-1.el7_1.noarch.rpm                     |  93 kB  00:00:00     
(39/53): python-qpid-qmf-1.35.0-1.el7.x86_64.rpm                      | 170 kB  00:00:00     
(40/53): python-saslwrapper-0.16-5.el7.x86_64.rpm                     |  26 kB  00:00:00     
(41/53): python-six-1.9.0-2.el7.noarch.rpm                            |  29 kB  00:00:00     
(42/53): python-semantic_version-2.4.2-1.el7.noarch.rpm               |  23 kB  00:00:00     
(43/53): pytz-2012d-5.el7.noarch.rpm                                  |  38 kB  00:00:00     
(44/53): python-urllib3-1.10.2-2.el7_1.noarch.rpm                     | 100 kB  00:00:00     
(45/53): python2-simplejson-3.10.0-1.el7.x86_64.rpm                   | 188 kB  00:00:00     
(46/53): python-billiard-3.3.0.20-2.el7.x86_64.rpm                    | 173 kB  00:00:03     
(47/53): qpid-qmf-1.35.0-1.el7.x86_64.rpm                             | 160 kB  00:00:00     
(48/53): setools-libs-3.3.8-1.1.el7.x86_64.rpm                        | 610 kB  00:00:00     
(49/53): qpid-tools-1.35.0-1.el7.noarch.rpm                           | 144 kB  00:00:00     
(50/53): saslwrapper-0.16-5.el7.x86_64.rpm                            |  19 kB  00:00:00     
mod_xsendfile-0.12-10.el7.x86_ FAILED                                          
http://mirror.es.its.nyu.edu/epel/7/x86_64/m/mod_xsendfile-0.12-10.el7.x86_64.rpm: [Errno 12] Timeout on http://mirror.es.its.nyu.edu/epel/7/x86_64/m/mod_xsendfile-0.12-10.el7.x86_64.rpm: (28, 'Connection timed out after 30001 milliseconds')
Trying other mirror.
(51/53): mod_xsendfile-0.12-10.el7.x86_64.rpm                         |  16 kB  00:00:00     

Error downloading packages:
  python-amqp-1.4.9-1.el7.noarch: [Errno 256] No more mirrors to try.
  python-celery-3.1.11-1.el7.noarch: [Errno 256] No more mirrors to try.

[root@qe-blade-13 yum.repos.d]# 

History

#1 Updated by pthomas@redhat.com about 2 years ago


pulp-installer failure

TASK [pulp : Install Pulp Server] **********************************************
fatal: [cloud-qe-06.idmqe.lab.eng.bos.redhat.com]: FAILED! => {"changed": true, "failed": true, "msg": "warning: /var/cache/yum/x86_64/7Server/rhel-7-server-rpms/packages/libsemanage-2.5-5.1.el7_3.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY\nhttps://repos.fedorapeople.org/pulp/pulp/beta/2.12/7Server/x86_64/python-amqp-1.4.9-1.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=pulp clean metadata\nTrying other mirror.\nhttps://repos.fedorapeople.org/pulp/pulp/beta/2.12/7Server/x86_64/python-celery-3.1.11-1.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=pulp clean metadata\nTrying other mirror.\n\n\nError downloading packages:\n  python-celery-3.1.11-1.el7.noarch: [Errno 256] No more mirrors to try.\n  python-amqp-1.4.9-1.el7.noarch: [Errno 256] No more mirrors to try.\n\n", "rc": 1, "results": ["Loaded plugins: product-id, search-disabled-repos, subscription-manager\nResolving Dependencies\n--> Running transaction check\n---> Package pulp-docker-plugins.noarch 0:2.3.0-1.el7 will be installed\n--> Processing Dependency: python-pulp-docker-common = 2.3.0 for package: pulp-docker-plugins-2.3.0-1.el7.noarch\n--> Processing Dependency: python-pulp-common >= 2.10.0 for package: pulp-docker-plugins-2.3.0-1.el7.noarch\n--> Processing Dependency: python-nectar >= 1.3.0 for package: pulp-docker-plugins-2.3.0-1.el7.noarch\n---> Package pulp-puppet-plugins.noarch 0:2.12.1-0.1.beta.el7 will be installed\n--> Processing Dependency: python-pulp-puppet-common = 2.12.1 for package: pulp-puppet-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-semantic_version >= 2.2.0 for package: pulp-puppet-plugins-2.12.1-0.1.beta.el7.noarch\n---> Package pulp-rpm-plugins.noarch 0:2.12.1-0.1.beta.el7 will be installed\n--> Processing Dependency: python-pulp-rpm-common = 2.12.1 for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-pulp-oid_validation >= 2.7.0 for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: createrepo_c >= 0.4.1-1 for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: createrepo >= 0.9.9-21 for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: repoview for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-deltarpm for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: genisoimage for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: deltarpm for package: pulp-rpm-plugins-2.12.1-0.1.beta.el7.noarch\n---> Package pulp-selinux.noarch 0:2.12.1-0.1.beta.el7 will be installed\n--> Processing Dependency: policycoreutils-python for package: pulp-selinux-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: /usr/sbin/semanage for package: pulp-selinux-2.12.1-0.1.beta.el7.noarch\n---> Package pulp-server.noarch 0:2.12.1-0.1.beta.el7 will be installed\n--> Processing Dependency: python-pulp-repoauth = 2.12.1 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-celery < 3.2.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-pymongo >= 3.0.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-oauth2 >= 1.5.211 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-mongoengine >= 0.10.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-gofer >= 2.5 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-django >= 1.4.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-celery >= 3.1.0 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: mod_xsendfile >= 0.12 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: mod_wsgi >= 3.4-1.pulp for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-ldap for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-httplib2 for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: python-blinker for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: mod_ssl for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: kobo for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n--> Processing Dependency: httpd for package: pulp-server-2.12.1-0.1.beta.el7.noarch\n---> Package python-gofer-qpid.noarch 0:2.7.6-1.el7 will be installed\n---> Package python-qpid.noarch 0:1.35.0-1.el7 will be installed\n--> Processing Dependency: python-qpid-common = 1.35.0-1.el7 for package: python-qpid-1.35.0-1.el7.noarch\n---> Package qpid-tools.noarch 0:1.35.0-1.el7 will be installed\n--> Processing Dependency: python-qpid-qmf for package: qpid-tools-1.35.0-1.el7.noarch\n--> Running transaction check\n---> Package createrepo.noarch 0:0.9.9-26.el7 will be installed\n---> Package createrepo_c.x86_64 0:0.9.0-1.el7 will be installed\n--> Processing Dependency: createrepo_c-libs = 0.9.0-1.el7 for package: createrepo_c-0.9.0-1.el7.x86_64\n--> Processing Dependency: libcreaterepo_c.so.0()(64bit) for package: createrepo_c-0.9.0-1.el7.x86_64\n---> Package deltarpm.x86_64 0:3.6-3.el7 will be installed\n---> Package genisoimage.x86_64 0:1.1.11-23.el7 will be installed\n--> Processing Dependency: libusal = 1.1.11-23.el7 for package: genisoimage-1.1.11-23.el7.x86_64\n--> Processing Dependency: librols.so.0()(64bit) for package: genisoimage-1.1.11-23.el7.x86_64\n--> Processing Dependency: libusal.so.0()(64bit) for package: genisoimage-1.1.11-23.el7.x86_64\n---> Package httpd.x86_64 0:2.4.6-45.el7 will be installed\n--> Processing Dependency: httpd-tools = 2.4.6-45.el7 for package: httpd-2.4.6-45.el7.x86_64\n---> Package kobo.noarch 0:0.5.1-1.el7 will be installed\n---> Package mod_ssl.x86_64 1:2.4.6-45.el7 will be installed\n---> Package mod_wsgi.x86_64 0:3.4-12.el7_0 will be installed\n---> Package mod_xsendfile.x86_64 0:0.12-10.el7 will be installed\n---> Package policycoreutils-python.x86_64 0:2.5-11.el7_3 will be installed\n--> Processing Dependency: policycoreutils = 2.5-11.el7_3 for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libsemanage-python >= 2.5-5 for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libcgroup for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64\n--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-11.el7_3.x86_64\n---> Package python-blinker.noarch 0:1.3-2.el7 will be installed\n---> Package python-celery.noarch 0:3.1.11-1.el7 will be installed\n--> Processing Dependency: python-kombu >= 3.0.15 for package: python-celery-3.1.11-1.el7.noarch\n--> Processing Dependency: python-billiard >= 3.3.0.17 for package: python-celery-3.1.11-1.el7.noarch\n--> Processing Dependency: pytz for package: python-celery-3.1.11-1.el7.noarch\n--> Processing Dependency: python-anyjson for package: python-celery-3.1.11-1.el7.noarch\n--> Processing Dependency: python-amqp for package: python-celery-3.1.11-1.el7.noarch\n---> Package python-deltarpm.x86_64 0:3.6-3.el7 will be installed\n---> Package python-django.noarch 0:1.6.11-5.el7 will be installed\n--> Processing Dependency: python-django-bash-completion = 1.6.11-5.el7 for package: python-django-1.6.11-5.el7.noarch\n---> Package python-gofer.noarch 0:2.7.6-1.el7 will be installed\n---> Package python-httplib2.noarch 0:0.7.7-3.el7 will be installed\n---> Package python-isodate.noarch 0:0.5.0-4.pulp.el7 will be installed\n---> Package python-ldap.x86_64 0:2.4.15-2.el7 will be installed\n---> Package python-mongoengine.noarch 0:0.10.5-1.el7 will be installed\n--> Processing Dependency: python-pymongo-gridfs >= 3.2 for package: python-mongoengine-0.10.5-1.el7.noarch\n---> Package python-nectar.noarch 0:1.5.3-1.el7 will be installed\n--> Processing Dependency: python-requests >= 2.4.3 for package: python-nectar-1.5.3-1.el7.noarch\n---> Package python-oauth2.noarch 0:1.5.211-8.el7 will be installed\n--> Processing Dependency: python-simplejson for package: python-oauth2-1.5.211-8.el7.noarch\n---> Package python-pulp-common.noarch 0:2.12.1-0.1.beta.el7 will be installed\n---> Package python-pulp-docker-common.noarch 0:2.3.0-1.el7 will be installed\n---> Package python-pulp-oid_validation.noarch 0:2.12.1-0.1.beta.el7 will be installed\n---> Package python-pulp-puppet-common.noarch 0:2.12.1-0.1.beta.el7 will be installed\n---> Package python-pulp-repoauth.noarch 0:2.12.1-0.1.beta.el7 will be installed\n---> Package python-pulp-rpm-common.noarch 0:2.12.1-0.1.beta.el7 will be installed\n---> Package python-pymongo.x86_64 0:3.2-1.el7 will be installed\n--> Processing Dependency: python-bson = 3.2-1.el7 for package: python-pymongo-3.2-1.el7.x86_64\n---> Package python-qpid-common.noarch 0:1.35.0-1.el7 will be installed\n---> Package python-qpid-qmf.x86_64 0:1.35.0-1.el7 will be installed\n--> Processing Dependency: qpid-qmf(x86-64) = 1.35.0-1.el7 for package: python-qpid-qmf-1.35.0-1.el7.x86_64\n--> Processing Dependency: libqmf2.so.1()(64bit) for package: python-qpid-qmf-1.35.0-1.el7.x86_64\n---> Package python-semantic_version.noarch 0:2.4.2-1.el7 will be installed\n---> Package repoview.noarch 0:0.6.6-4.el7 will be installed\n--> Processing Dependency: python-kid >= 0.6.3 for package: repoview-0.6.6-4.el7.noarch\n--> Running transaction check\n---> Package audit-libs-python.x86_64 0:2.6.5-3.el7 will be installed\n---> Package checkpolicy.x86_64 0:2.5-4.el7 will be installed\n---> Package createrepo_c-libs.x86_64 0:0.9.0-1.el7 will be installed\n---> Package httpd-tools.x86_64 0:2.4.6-45.el7 will be installed\n---> Package libcgroup.x86_64 0:0.41-11.el7 will be installed\n---> Package libsemanage-python.x86_64 0:2.5-5.1.el7_3 will be installed\n--> Processing Dependency: libsemanage = 2.5-5.1.el7_3 for package: libsemanage-python-2.5-5.1.el7_3.x86_64\n---> Package libusal.x86_64 0:1.1.11-23.el7 will be installed\n---> Package policycoreutils.x86_64 0:2.5-8.el7 will be updated\n---> Package policycoreutils.x86_64 0:2.5-11.el7_3 will be an update\n---> Package python-IPy.noarch 0:0.75-6.el7 will be installed\n---> Package python-amqp.noarch 0:1.4.9-1.el7 will be installed\n---> Package python-anyjson.noarch 0:0.3.3-3.el7 will be installed\n---> Package python-billiard.x86_64 1:3.3.0.20-2.el7 will be installed\n---> Package python-bson.x86_64 0:3.2-1.el7 will be installed\n---> Package python-django-bash-completion.noarch 0:1.6.11-5.el7 will be installed\n---> Package python-kid.noarch 0:0.9.6-11.el7 will be installed\n---> Package python-kombu.noarch 1:3.0.33-6.pulp.el7 will be installed\n---> Package python-pymongo-gridfs.x86_64 0:3.2-1.el7 will be installed\n---> Package python-requests.noarch 0:2.6.0-1.el7_1 will be installed\n--> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-1.el7_1.noarch\n---> Package python2-simplejson.x86_64 0:3.10.0-1.el7 will be installed\n---> Package pytz.noarch 0:2012d-5.el7 will be installed\n---> Package qpid-qmf.x86_64 0:1.35.0-1.el7 will be installed\n---> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be installed\n--> Running transaction check\n---> Package libsemanage.x86_64 0:2.5-4.el7 will be updated\n---> Package libsemanage.x86_64 0:2.5-5.1.el7_3 will be an update\n---> Package python-urllib3.noarch 0:1.10.2-2.el7_1 will be installed\n--> Processing Dependency: python-six for package: python-urllib3-1.10.2-2.el7_1.noarch\n--> Running transaction check\n---> Package python-six.noarch 0:1.9.0-2.el7 will be installed\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package                    Arch   Version             Repository          Size\n================================================================================\nInstalling for group install \"Pulp Server and Qpid Client Packages\":\n pulp-docker-plugins        noarch 2.3.0-1.el7         pulp                94 k\n pulp-puppet-plugins        noarch 2.12.1-0.1.beta.el7 pulp               104 k\n pulp-rpm-plugins           noarch 2.12.1-0.1.beta.el7 pulp               328 k\n pulp-selinux               noarch 2.12.1-0.1.beta.el7 pulp                79 k\n pulp-server                noarch 2.12.1-0.1.beta.el7 pulp               763 k\n python-gofer-qpid          noarch 2.7.6-1.el7         pulp                53 k\n python-qpid                noarch 1.35.0-1.el7        epel                94 k\n qpid-tools                 noarch 1.35.0-1.el7        epel               144 k\nInstalling for dependencies:\n audit-libs-python          x86_64 2.6.5-3.el7         beaker-Server       70 k\n checkpolicy                x86_64 2.5-4.el7           beaker-Server      290 k\n createrepo                 noarch 0.9.9-26.el7        beaker-Server       92 k\n createrepo_c               x86_64 0.9.0-1.el7         epel                68 k\n createrepo_c-libs          x86_64 0.9.0-1.el7         epel                85 k\n deltarpm                   x86_64 3.6-3.el7           beaker-Server       82 k\n genisoimage                x86_64 1.1.11-23.el7       beaker-Server      298 k\n httpd                      x86_64 2.4.6-45.el7        beaker-Server      1.2 M\n httpd-tools                x86_64 2.4.6-45.el7        beaker-Server       84 k\n kobo                       noarch 0.5.1-1.el7         epel               100 k\n libcgroup                  x86_64 0.41-11.el7         beaker-Server       65 k\n libsemanage-python         x86_64 2.5-5.1.el7_3       rhel-7-server-rpms 104 k\n libusal                    x86_64 1.1.11-23.el7       beaker-Server      135 k\n mod_ssl                    x86_64 1:2.4.6-45.el7      beaker-Server      105 k\n mod_wsgi                   x86_64 3.4-12.el7_0        beaker-Server       76 k\n mod_xsendfile              x86_64 0.12-10.el7         epel                16 k\n policycoreutils-python     x86_64 2.5-11.el7_3        rhel-7-server-rpms 445 k\n python-IPy                 noarch 0.75-6.el7          beaker-Server       32 k\n python-amqp                noarch 1.4.9-1.el7         pulp                87 k\n python-anyjson             noarch 0.3.3-3.el7         epel                13 k\n python-billiard            x86_64 1:3.3.0.20-2.el7    epel               173 k\n python-blinker             noarch 1.3-2.el7           rhel-7-server-extras-rpms\n                                                                           93 k\n python-bson                x86_64 3.2-1.el7           pulp               192 k\n python-celery              noarch 3.1.11-1.el7        pulp               1.8 M\n python-deltarpm            x86_64 3.6-3.el7           beaker-Server       31 k\n python-django              noarch 1.6.11-5.el7        epel               4.0 M\n python-django-bash-completion\n                            noarch 1.6.11-5.el7        epel                16 k\n python-gofer               noarch 2.7.6-1.el7         pulp               132 k\n python-httplib2            noarch 0.7.7-3.el7         epel                70 k\n python-isodate             noarch 0.5.0-4.pulp.el7    pulp                50 k\n python-kid                 noarch 0.9.6-11.el7        epel               158 k\n python-kombu               noarch 1:3.0.33-6.pulp.el7 pulp               486 k\n python-ldap                x86_64 2.4.15-2.el7        beaker-Server      159 k\n python-mongoengine         noarch 0.10.5-1.el7        pulp               407 k\n python-nectar              noarch 1.5.3-1.el7         pulp                47 k\n python-oauth2              noarch 1.5.211-8.el7       epel                28 k\n python-pulp-common         noarch 2.12.1-0.1.beta.el7 pulp               123 k\n python-pulp-docker-common  noarch 2.3.0-1.el7         pulp                37 k\n python-pulp-oid_validation noarch 2.12.1-0.1.beta.el7 pulp                65 k\n python-pulp-puppet-common  noarch 2.12.1-0.1.beta.el7 pulp                32 k\n python-pulp-repoauth       noarch 2.12.1-0.1.beta.el7 pulp                77 k\n python-pulp-rpm-common     noarch 2.12.1-0.1.beta.el7 pulp                66 k\n python-pymongo             x86_64 3.2-1.el7           pulp               349 k\n python-pymongo-gridfs      x86_64 3.2-1.el7           pulp               146 k\n python-qpid-common         noarch 1.35.0-1.el7        epel               286 k\n python-qpid-qmf            x86_64 1.35.0-1.el7        epel               170 k\n python-requests            noarch 2.6.0-1.el7_1       beaker-Server       93 k\n python-semantic_version    noarch 2.4.2-1.el7         epel                23 k\n python-six                 noarch 1.9.0-2.el7         beaker-Server       29 k\n python-urllib3             noarch 1.10.2-2.el7_1      beaker-Server      100 k\n python2-simplejson         x86_64 3.10.0-1.el7        epel               188 k\n pytz                       noarch 2012d-5.el7         beaker-Server       38 k\n qpid-qmf                   x86_64 1.35.0-1.el7        epel               160 k\n repoview                   noarch 0.6.6-4.el7         epel                40 k\n setools-libs               x86_64 3.3.8-1.1.el7       beaker-Server      610 k\nUpdating for dependencies:\n libsemanage                x86_64 2.5-5.1.el7_3       rhel-7-server-rpms 145 k\n policycoreutils            x86_64 2.5-11.el7_3        rhel-7-server-rpms 842 k\n\nTransaction Summary\n================================================================================\nInstall  8 Packages (+55 Dependent packages)\nUpgrade             (  2 Dependent packages)\n\nTotal download size: 16 M\nDownloading packages:\nDelta RPMs disabled because /usr/bin/applydeltarpm not installed.\nPublic key for libsemanage-2.5-5.1.el7_3.x86_64.rpm is not installed\nPublic key for python-blinker-1.3-2.el7.noarch.rpm is not installed\n"]}

RUNNING HANDLER [pulp : Save IPv4 iptables configuration] **********************
    to retry, use: --limit @/home/jenkins/workspace/pulp-installer/ci/ansible/pulp_server.retry

PLAY RECAP *********************************************************************
cloud-qe-06.idmqe.lab.eng.bos.redhat.com : ok=17   changed=14   unreachable=0    failed=1   

#2 Updated by pthomas@redhat.com about 2 years ago

  • Blocks Release 2.12.z added

#3 Updated by bizhang about 2 years ago

It looks like some of the packages were added to the repo after the repo was created, which is unexpected. I probably made a mistake somewhere while building, and will keep check the last updated time for the packages when building GA.

I re-rsync'd the packages, and a simple test of
`yum install python-amqp-1.4.9`
now installs the package as expected

#4 Updated by pthomas@redhat.com about 2 years ago

  • Verified changed from No to Yes

Verified that 2.12.1 beta can be installed on el7 and fedora 24 without any dependency issues.

#5 Updated by bizhang about 2 years ago

  • Status changed from NEW to ON_QA

#6 Updated by semyers about 2 years ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE
  • Blocks Release deleted (2.12.z)

I believe that we fixed this by republishing the repo, and this is no longer blocking 2.12.z.

#7 Updated by bmbouter 5 days ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF