Project

Profile

Help

Issue #2528

For pulp-manage-db prerequisites: Add pulp_streamer to list of services that should not be running

Added by tcarlin@redhat.com about 3 years ago. Updated 10 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Master
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

https://github.com/pulp/pulp/pull/2903/files has docs/user-guide/release-notes/2.12.x.rst changes which list the other services but omit pulp_streamer.service:
"``pulp-manage-db`` will not continue if pulp_celerybeat, pulp_resource_manager, or pulp_workers
+ processes are running. This will prevent the user from corrupting their Pulp installation by
+ migrating with running workers. This works in both standalone and clustered installations. Pulp
+ may wait up to 92 seconds to determine if workers are running."


Related issues

Duplicates Pulp - Story #2529: As a user, pulp-manage-db will not run if the pulp_streamer service is running CLOSED - WONTFIX Actions
Duplicates Pulp - Story #2530: As a user, pulp-manage-db will not run if httpd is running CLOSED - WONTFIX Actions

History

#1 Updated by bmbouter about 3 years ago

First off, I'm delighted you filed this. It's not often a non-core member points out a pre-beta issue in the code!

In this case (unfortunately) the note is correct. Currently, Pulp is not able to check if pulp_streamer or httpd are running. I can understand wanting to have those check also, but that would be a new feature since we would need those components to "heartbeat" like pulp_celerybeat, pulp_resource_manager, and pulp_workers do today.

So given ^ do you want to file two new stories requesting that functionality? One for pulp_streamer and one for httpd? Since the docs are correct, I think this should be closed as NOTABUG.

@tcarlin, what do you think?

#2 Updated by tcarlin@redhat.com about 3 years ago

I believe there are separate issues:
  • There should be some type of warning to administrators since the result may be Pulp database corruption. This was my original intent in filing this issue
  • I agree with you that determining if pulp_streamer or httpd would indeed be separate issues. I will file them so the work is properly segregated.

Thank you for your thoughtful response.

#3 Updated by bmbouter about 3 years ago

I touched up the language some on the stories you filed, #2529 and #2530.

In order to do that, we need those components to heartbeat so I've created tasks for each of those as #2534 and #2535. Those would have to be done first, so I added a blocking relationship between the issues.

This request seems to be well captured in #2529 and #2530, so I think closing this as duplicate of #2529 and #2530 would be productive.

@tcarlin, how does ^ sound?

#4 Updated by bmbouter about 3 years ago

  • Tags deleted (Documentation, Easy Fix)

#5 Updated by tcarlin@redhat.com about 3 years ago

Sounds like a plan. If we do have downstream cases relating, we can link to these 3 issues at that time.

#6 Updated by bmbouter about 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#7 Updated by bmbouter about 3 years ago

  • Duplicates Story #2529: As a user, pulp-manage-db will not run if the pulp_streamer service is running added

#8 Updated by bmbouter about 3 years ago

  • Duplicates Story #2530: As a user, pulp-manage-db will not run if httpd is running added

#9 Updated by bmbouter 10 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF