Project

Profile

Help

Issue #2474

CentOs repo that was synced in 2.8 results in "Task Failed Importer indicated a failed response" after upgrade to 2.11

Added by pthomas@redhat.com almost 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.11.0
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Centos 7 repo which was synced in 2.8 fails sync with "Task Failed Importer indicated a failed response" after upgrade to 2.11

1. In 2.8 create a centos repo with the feed http://ftp.linux.ncsu.edu/pub/CentOS/7/os/x86_64/
2. Sync the repo
3. Upgrade to 2.11
4. Run migration
5. Restart services
6.Resync the centos repo

[root@ibm-x3550m3-06 ~]# pulp-admin rpm repo sync run --repo-id centos7
+----------------------------------------------------------------------+
                   Synchronizing Repository [centos7]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.

Downloading metadata...
[\]
... completed

Downloading repository content...
[\]
[==================================================] 100%
RPMs:       0/0 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 6/6 items

Task Failed

Importer indicated a failed response

log

ec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128) No connection adapters were found for 'ftp://ftp.linux.ncsu.edu//pub/CentOS/7/os/x86_64/images/boot.iso'
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128) Traceback (most recent call last):
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/nectar/downloaders/threaded.py", line 272, in _fetch
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     **requests_kwargs)
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 476, in get
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     return self.request('GET', url, **kwargs)
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 464, in request
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     resp = self.send(prep, **send_kwargs)
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 602, in send
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     history = [resp for resp in gen] if allow_redirects else []
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 195, in resolve_redirects
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     allow_redirects=False,
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 570, in send
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     adapter = self.get_adapter(url=request.url)
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)   File "/usr/lib/python2.6/site-packages/requests/sessions.py", line 649, in get_adapter
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128)     raise InvalidSchema("No connection adapters were found for '%%s'" %% url)
Dec  6 17:25:41 ibm-x3550m3-06 pulp: nectar.downloaders.threaded:ERROR: (17932-68128) InvalidSchema: No connection adapters were found for 'ftp://ftp.linux.ncsu.edu//pub/CentOS/7/os/x86_64/images/boot.iso'
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.parse.treeinfo:ERROR: some distro file downloads failed
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872) 
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872) Traceback (most recent call last):
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/sync.py", line 275, in run
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)     dist_sync.run()
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/parse/treeinfo.py", line 128, in run
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)     self._run(tmp_dir)
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/parse/treeinfo.py", line 199, in _run
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)     for destination, location in downloaded:
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)   File "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/parse/treeinfo.py", line 288, in download_files
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872)     raise DownloadFailed()
Dec  6 17:26:04 ibm-x3550m3-06 pulp: pulp_rpm.plugins.importers.yum.sync:ERROR: (17932-23872) DownloadFailed
Dec  6 17:26:05 ibm-x3550m3-06 pulp: pulp.server.async.tasks:INFO: Task failed : [27110bd3-c995-4c76-b254-234c7a7b4974]
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872) Task pulp.server.managers.repo.sync.sync[27110bd3-c995-4c76-b254-234c7a7b4974] raised unexpected: PulpExecutionException('Importer indicated a failed response',)
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872) Traceback (most recent call last):
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)   File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 240, in trace_task
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)     R = retval = fun(*args, **kwargs)
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 488, in __call__
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)     return super(Task, self).__call__(*args, **kwargs)
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 103, in __call__
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)     return super(PulpTask, self).__call__(*args, **kwargs)
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)   File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 437, in __protected_call__
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)     return self.run(*args, **kwargs)
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)   File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 816, in sync
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872)     raise pulp_exceptions.PulpExecutionException(_('Importer indicated a failed response'))
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:ERROR: (17878-23872) PulpExecutionException: Importer indicated a failed response
Dec  6 17:26:05 ibm-x3550m3-06 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[efa28456-694f-4924-b055-a6d0cdfd066f] succeeded in 0.00840502799838s: None

Related issues

Is duplicate of Nectar - Issue #1736: Nectar fails to handle redirects to FTP gracefully.CLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by semyers almost 4 years ago

I think that this is a duplicate of https://pulp.plan.io/issues/1736. It is not a regression, and does not qualify as a blocking issue.

While the feed URL is "http://ftp.linux.ncsu.edu/pub/CentOS/7/os/x86_64/", note that the actual URL nectar chokes on is "ftp://ftp.linux.ncsu.edu//pub/CentOS/7/os/x86_64/images/boot.iso"

#2 Updated by pthomas@redhat.com almost 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Closing as duplicate as per the comment above.

#3 Updated by pthomas@redhat.com almost 4 years ago

  • Related to Issue #1736: Nectar fails to handle redirects to FTP gracefully. added

#4 Updated by bmbouter almost 4 years ago

  • Related to deleted (Issue #1736: Nectar fails to handle redirects to FTP gracefully.)

#5 Updated by bmbouter almost 4 years ago

  • Is duplicate of Issue #1736: Nectar fails to handle redirects to FTP gracefully. added

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF