Project

Profile

Help

Story #240

YUM repositories using deltainfo don't get delta RPMs published

Added by kvedulv@kvedulv.de over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1120215 ++

Description of problem:

Description of problem:
YUM repositories using deltainfo instead of prestodelta don't get their Delta-RPMs synced into the published repo.

Version-Release number of selected component (if applicable):
2.4beta23

How reproducible:
always

Steps to Reproduce:
1. Patch pulp with https://github.com/pulp/pulp_rpm/pull/525 to work around missing name element im collection of SUSE repos.
2. Import and publish attached test repo.
3. Try a zypper update on the client.

Actual results:
Delta RPMs are missing

Expected results:
Delta RPMs are in the published repo

--- Additional comment from at 07/16/2014 16:30:58 ---

Thank you for finding both of these incompatibilities between pulp and SUSE content. We want to support SUSE content, and this will be very helpful in making that happen.

A diligent investigation of the schema for the deltainfo file vs. the prestodelta file will be required before we can implement this. Any additional help with that would be quite welcome.

--- Additional comment from at 07/16/2014 21:57:35 ---

http://en.opensuse.org/openSUSE:Standards_Rpm_Metadata says:
deltainfo.xml used to support delta rpms. Format is the same as yum-presto
A glance at those deltainfo.xml files is also confirming that, so it shouldn't be hard to fix.

Unfortunately I don't have a clue how to handle that in the importer, as PRESTO_DELTA_FILE_NAME = 'prestodelta.xml.gz' doesn't leave much room for or-clauses. ;)

It would probably make sense to publish the contents of a generated prestodelta.xml also as deltainfo.xml so zypper/yast can consume it.

--- Additional comment from at 07/18/2014 11:03:45 ---

Workaround at https://github.com/pulp/pulp_rpm/pull/527

--- Additional comment from at 01/12/2015 17:15:27 ---

Michael Moll, With some browsing & testing I did, it appeared that zypper will read the presto-delta.xml.gz file if it is in the repository. Can you confirm whether or not the file must be named deltainfo if zypper will use a presto-delta file if it is found instead.

There is another patch at https://github.com/pulp/pulp_rpm/pull/629 that will ensure that all the information is synced into a pulp repository. It's just a matter of how it is published. In this case it is vastly simpler if we can always use presto-delta as the name of the output file.

--- Additional comment from at 01/16/2015 13:58:44 ---

After changing employers, I don't have a pulp instance around to test at the moment, sorry... If your tests are positive with zypper from SLES 11 SP3 (that's the oldest still supported, I think), I'd say just go ahead. If real testing is needed, ping me again and I'll setup something.
Thanks for following up on that!


Related issues

Related to RPM Support - Task #927: Test with openSUSECLOSED - NOTABUG

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 5 years ago

  • Related to Task #927: Test with openSUSE added

#2 Updated by darkfader over 4 years ago

Hi, you can also contact me for testing needs but as OP said, just put it in, those work. I used them w/o issue.

#3 Updated by kvedulv@kvedulv.de over 4 years ago

this can be set to resolved/closed now anyway :)

#4 Updated by bmbouter over 4 years ago

  • Status changed from NEW to CLOSED - NOTABUG

Per the last 2 comments, setting this issue to CLOSED - NOTABUG. Please reopen if this is suspected to be a non-working feature.

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF