Project

Profile

Help

Issue #2110

Support for first class 'generic' or 'file' content type

Added by ehelms@redhat.com about 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

We currently use the "iso" content type for providing users with a generic sync or upload anything content (we call it "file") type. I think this is a powerful feature that would allow Pulp (and thus Katello) users to manage nearly anything using repositories, federation, and replication across remote nodes. For some content this would allow a gateway to their use until a more official plugin supporting that ecosystem is derived (e.g. users can import debian content or gems).


Related issues

Is duplicate of RPM Support - Refactor #119: Rename the ISO plugins to be "File" pluginsCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com about 5 years ago

  • Is duplicate of Refactor #119: Rename the ISO plugins to be "File" plugins added

#2 Updated by amacdona@redhat.com about 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF