Project

Profile

Help

Story #211

[RFE] pulp allows corrupt rpms to be pushed into repos

Added by Anonymous over 5 years ago. Updated 6 months ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #1023335 ++

Description of problem:

Description of problem:
I create a repo, and push to it a corrupt rpm, which won't install.

Version-Release number of selected component (if applicable):
2.2.0-1

How reproducible:
always

Steps to Reproduce:

1. locate a corrupt rpm:
rpm -K /tmp/corruptrpm-1.0-1.noarch.rpm: RSA sha1 ((MD5) PGP) md5 NOT OK (MISSING KEYS: (MD5) PGP#f44e7eb7)

2. pulp-admin rpm repo create --repo-id test-repo2 --relative-url test-repo2

3. pulp-admin rpm repo uploads rpm -f /tmp/corruptrpm-1.0-1.noarch.rpm --repo-id=test-repo2
----------------------------------------------------------------------
Unit Upload
--------------------------------------------------------------------

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: corruptrpm-1.0-1.noarch.rpm
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: corruptrpm-1.0-1.noarch.rpm
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: corruptrpm-1.0-1.noarch.rpm
[==================================================] 100%
2729160/2729160 bytes
... completed

Importing into the repository...
... completed

Deleting the upload request...
... completed

Actual results:

Corrult rpm successfully pushed into pulp.

Expected results:

rpm upload should fail due to incorrect checksum

Additional info:

--- Additional comment from at 10/25/2013 08:49:45 ---

this was not a corrupt rpm after all.

--- Additional comment from at 11/11/2013 14:49:22 ---

This also is applicable with actual corrupt rpm:s with sha1sum mismatch,.

--- Additional comment from at 11/13/2013 16:56:04 ---

***** Bug 1029085 has been marked as a duplicate of this bug. ***

History

#1 Updated by bmbouter over 5 years ago

  • Tags deleted (Reopened)

#2 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF