Project

Profile

Help

Story #2058

closed

As a user, I can get time-bombed URLs to access unit files

Added by mhrivnak over 7 years ago. Updated over 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

In environments where unit content is protected by some kind of auth, apps that integrate with pulp could provide a time-bombed unit file URL to their users. An example would be katello allowing users to download an RPM from the web UI. Katello would request a time-bombed URL from pulp and make that available to an end user, who could then access the file without otherwise authenticating to pulp.


Related issues

Is duplicate of Pulp - Story #1315: As a user, I can access time based urls to pull down unit filesCLOSED - WONTFIX

Actions
Actions #1

Updated by mhrivnak over 7 years ago

  • Blocked by Story #2057: As a user, I can download unit files through the API added
Actions #2

Updated by mhrivnak over 7 years ago

  • Blocked by deleted (Story #2057: As a user, I can download unit files through the API)
Actions #3

Updated by mhrivnak over 7 years ago

  • Is duplicate of Story #1315: As a user, I can access time based urls to pull down unit files added
Actions #4

Updated by mhrivnak over 7 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #5

Updated by bmbouter almost 5 years ago

  • Tags Pulp 2 added
Actions #6

Updated by bmbouter over 3 years ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Also available in: Atom PDF