Project

Profile

Help

Story #205

closed

[RFE] add option to make pulp-admin output machine-readable

Added by djuran@redhat.com almost 8 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

++ This bug was initially created as a clone of Bugzilla Bug #994137 ++

Description of problem:

Description of problem:
If you have a really long repository ID, e.g. "pulp-admin repo list" will add a line-break to it's output. This make it hard to use grep and similar on the output.

Version-Release number of selected component (if applicable):
pulp-2.1.1-1.el6

How reproducible:
Every time

Steps to Reproduce:
1. pulp-admin repo list
Id: ACMEXX-rhel-6-server-x86_64-appdev-game-execution-environme
nt
Display Name: ACMEXX-rhel-6-server-x86_64-appdev-game-execution-environme
nt
Description: None
Content Unit Counts:
Rpm: 262

Actual results:
Do note the line breaks in the Id and Display name


Related issues

Is duplicate of Pulp - Story #929: As a user, I can machine-parse pulp-admin outputCLOSED - WONTFIX

Actions
Actions #1

Updated by mhrivnak over 7 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #2

Updated by mhrivnak over 7 years ago

  • Is duplicate of Story #929: As a user, I can machine-parse pulp-admin output added
Actions #3

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added
Actions #4

Updated by Ottelf over 1 year ago

I know what you will do in the near future, because now I will leave for you a link to the site https://nodepositz.com/ where you can find the best online casino where you can easily make big money.

Also available in: Atom PDF