Project

Profile

Help

Story #204

Add ability to specify LDAP schema in order to be able to use Active Directory

Added by redbugzilla@0ack.com about 5 years ago. Updated about 2 hours ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

++ This bug was initially created as a clone of Bugzilla Bug #991685 ++

Description of problem:

Description of problem:
There is already an RFE for specifying bind credentials, however the code assumes that username (for example) will match against an attribute called "uid".
See the ldap_filter in the function lookup_user in pulp/platform/src/pulp/server/auth/ldap_connection.py

This may not be true for all LDAP servers, for example Active Directory.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
Always

Steps to Reproduce:
1. Have an LDAP server where username is not in an attribute called "uid"
2. LDAP authentication wont work because the user wont be found.
3.

Actual results:
Can't actually get this far, because we can't bind to AD with credentials yet.

Expected results:
Specify uid attribute as sAMAccountName
and others too, like:
gecos = displayName

Additional info:
Need to link this up with Bug 817063, since there is no point getting this done before that one; well for AD support anyway.

History

#2 Updated by bmbouter about 5 years ago

  • Subject changed from [RFE] Add ability to specify LDAP schema in order to be able to use Active Directory to Add ability to specify LDAP schema in order to be able to use Active Directory
  • Assignee deleted (skarmark@redhat.com)

#3 Updated by bmbouter 12 months ago

  • Status changed from NEW to CLOSED - WONTFIX

#4 Updated by bmbouter 12 months ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter 12 months ago

  • Tags Pulp 2 added

#6 Updated by jesusclay2018@gmail.com 4 months ago

LDAP has become the most interesting thing for youth. Now they spend most of their time of social media. They know how to change this world. most of the youth are playing games online or offline. Visit my Essay Writing Lab now. We can learn a lot from this that if you want to become a successful then you will have to give a proper time.

#7 Updated by lexiedwards 2 months ago

LDAP schema is a set of rules that define what can be stored as entries. Thanks for supporting AD. Hnd assignment writing service

#8 Updated by eegair 2 months ago

There’s definitely a great deal to know about this topic. I love all the points you’ve made. marlboro gold cigarettes

#9 Updated by harperjackalive@gmail.com 24 days ago

You can also use the Active Directory Schema MMC snap-in, which splits the We'll specify the more commonly used LDAP display name format from now on. can someone write my assignment for me If the class you are adding will have custom attributes that are required to be

#10 Updated by AnwenStephen90 17 days ago

According to Legal Assignment Writers All hackers know that the key to the Internet is Active Directory (AD). When a hacker opens your user account, he will compete with you and your data security so you can stop it before the data breach begins.

#11 Updated by noah110 6 days ago

LDAP has become the most interesting thing among young people. Now they spend most of their time on social media. They know how to change the world. Most young people play games online or offline. Visit my write my essay for me cheap lab now. We can learn a lot and if you want to succeed you have to pay at the right time.

#12 Updated by william552 4 days ago

Pulp 2 is about to enter maintenance mode and the Pulp 2 token has not yet been processed. Therefore, it has been closed as WONT-FIX. However, Pulp 2 still accepts donations, so if you want to donate for this ticket, reopen or comment. If you are not authorized to reopen dissertation writers ticket or if you wish to discuss the problem.

#13 Updated by flavia110 2 days ago

Our agency comprises of a team of professionals who work together to bring you maximum satisfaction by providing high-quality service. These include professional essay writers, expert editors, skilled proofreaders, and essay tutors. Whether you are looking for your law essay help or nursing essay help, our experts are just a call away. So search no more and ask someone to write my essay for me because our essay writing service UK is at your service.

#14 Updated by oliver010 about 23 hours ago

The bug created by the LDAP was not just a trial, it actually do harm to the system , therefor connecting with a professional must be made a mandatory case, like i did for my dissertation help online for my course.

#15 Updated by flavia110 about 2 hours ago

The ability to modify the schema of your LDAP directory. with the group define the protocol and parameters of the connection, and users are allowed. [url=http://royaldissertationhelp.co.uk/nursing-dissertation-help-uk/ ]nursing dissertation writing[/url] Configuring Guacamole to use a database for authentication or connection storage is ...

Please register to edit this issue

Also available in: Atom PDF