Project

Profile

Help

Issue #2029

Cryptic error messages

Added by tmlcoch about 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Pulp fails with cryptic error message when trying to sync an inconsistent repository that has different set of packages in metadata files (e.g. primary.xml and other.xml).

The error message provided by Pulp is:

'\\xff\\xff\\xff\\xff\\xb0!\\x99\\x07'

Whole error:

Sync Incomplete 

PLP0000: Importer indicated a failed response

     {"yum_importer"=>
       {"content"=>
         {"size_total"=>5681420084,
          "items_left"=>10,
          "items_total"=>64,
          "state"=>"FAILED",
          "size_left"=>1486145600,
          "details"=>
           {"rpm_total"=>64, "rpm_done"=>54, "drpm_total"=>0, "drpm_done"=>0},
          "error"=>"'\\xff\\xff\\xff\\xff\\xb0!\\x99\\x07'",
          "error_details"=>[]},
        "comps"=>{"state"=>"NOT_STARTED"},
        "purge_duplicates"=>{"state"=>"NOT_STARTED"},
        "distribution"=>
         {"items_total"=>0,
          "state"=>"NOT_STARTED",
          "error_details"=>[],
          "items_left"=>0},
        "errata"=>{"state"=>"NOT_STARTED"},
        "metadata"=>{"state"=>"FINISHED"}}},

Please fix Pulp to provide some meaningful error messages.


Related issues

Is duplicate of RPM Support - Issue #1932: More gracefully handle KeyError when an rpm has no data in filelists.xml nor in other.xmlCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter about 5 years ago

This issue needs a specific reproducer. Please post commands that a developer could use to reproduce the issue. A pulp-smash showing the error would also work.

#2 Updated by mhrivnak about 5 years ago

Is this a duplicate of https://pulp.plan.io/issues/1932 ?

#3 Updated by tmlcoch about 5 years ago

Feel free to close this one if it's a duplicate.

Brian, you were on the original ticket with the issue. You know that I'm not the person who hit the issue and thus I have no reproducer. I opened the bug just to let Pulp team officially know about the issue so the bug can be triaged and ideally even fixed. If you need a reproducer for every reported Pulp issue then I'm afraid that overwhelming majority of bugs won't be ever fixed.

#4 Updated by bmbouter about 5 years ago

From the information provided this looks like a duplicate so I'm closing and marking as a duplicate.

tmlcoch: Every bug to be fixed needs to be reproduced. If you don't have a reproducer that is OK; sometimes I observe things that I don't have a clear reproducer for. Generally, bugs reported to Pulp need to be of the highest quality because that gives developers an opportunity to provide the best/quickest fixes. To that end, I recommend reading about how to write a good bug report: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

#5 Updated by bmbouter about 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Triaged changed from No to Yes

#6 Updated by bmbouter about 5 years ago

  • Is duplicate of Issue #1932: More gracefully handle KeyError when an rpm has no data in filelists.xml nor in other.xml added

#7 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF