Project

Profile

Help

Issue #2024

Summary listing of RPM repos appears to be broken

Added by kfiresmith over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.8.4
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 474, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 974, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/extensions.py", line 210, in execute
    return self.method(*arg_list, **clean_kwargs)
  File "/usr/lib/python2.7/site-packages/pulp/client/commands/repo/cudl.py", line 331, in run
    self.display_repository_summaries(**kwargs)
  File "/usr/lib/python2.7/site-packages/pulp/client/commands/repo/cudl.py", line 395, in display_repository_summaries
    _default_summary_view(repo_list, self.prompt)
  File "/usr/lib/python2.7/site-packages/pulp/client/commands/repo/cudl.py", line 535, in _default_summary_view
    name_value = repo['display_name'][0:max_name_width]
TypeError: 'NoneType' object has no attribute '__getitem__'
An unexpected error has occurred. More information may be found using the -v
flag.

http://paste.fedoraproject.org/382230/66444803/

History

#1 Updated by kfiresmith over 4 years ago

Whoops, forgot to include the command resulting in the error:

$pulp-admin -vvv rpm repo list --summary

If it's possible for non-team reporters to update their own original bugreport contents please let me know how. Can't seem to edit the original report :/

#2 Updated by bmbouter over 4 years ago

Kodiak: Redmine is a little kludge in this area, but I've given your user the right to edit issues now.

#3 Updated by amacdona@redhat.com over 4 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

#4 Updated by fdobrovo over 4 years ago

I'm sure that this is duplicate of already fixed https://pulp.plan.io/issues/1829

#5 Updated by fdobrovo over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF