Project

Profile

Help

Issue #2023

closed

Error while login in pulp-admin

Added by prakash.khadka over 6 years ago. Updated over 3 years ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.8.4
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
June 2015
Quarter:

Description

I do not know what went wrong exactly but as far as I remember I was working with pulp and juicer. If I install pymongo 2.7.0 then juicer works but pulp-admin didnt, and if I install pymongo to latest then pulp-admin works but juicer stops working. I think I messed something up, now when I try to login as user it gives me error::

  1. pulp-admin -v login -u admin
    Enter password:
    2016-06-20 07:22:03,165 - ERROR - Client-side exception occurred
    Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 474, in run
    exit_code = Cli.run(self, args)
    File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 974, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
    File "/usr/lib/python2.7/site-packages/pulp/client/extensions/extensions.py", line 210, in execute
    return self.method(*arg_list, **clean_kwargs)
    File "/usr/lib/python2.7/site-packages/pulp/client/admin/admin_auth.py", line 49, in login
    result = self.context.server.actions.login(username, password).response_body
    File "/usr/lib/python2.7/site-packages/pulp/bindings/actions.py", line 20, in login
    return self.server.POST (path)
    File "/usr/lib/python2.7/site-packages/pulp/bindings/server.py", line 100, in POST
    log_request_body=log_request_body, ignore_prefix=ignore_prefix)
    File "/usr/lib/python2.7/site-packages/pulp/bindings/server.py", line 166, in _request
    self._handle_exceptions(response_code, response_body)
    File "/usr/lib/python2.7/site-packages/pulp/bindings/server.py", line 207, in _handle_exceptions
    raise code_class_mappings[response_code](response_body)
    File "/usr/lib/python2.7/site-packages/pulp/bindings/exceptions.py", line 16, in init
    self.href = response_body.pop('_href', None)
    AttributeError: 'str' object has no attribute 'pop'
    An unexpected error has occurred. More information may be found using the -v
    flag.
Actions #1

Updated by bmbouter over 6 years ago

  • Status changed from NEW to CLOSED - NOTABUG
  • Triaged changed from No to Yes

pulp-server requires python-pymongo >= 3.0.0[0]. If juicer requires python-pymongo < 3.0.0 then juicer is incompatible on the same Python installation with Pulp. Juicer would need to update itself to be compatible with the newer version of pymongo to also be compatible with Pulp. The 3.0 pymongo release is a major release and is backwards incompatible with earlier version of pymongo, so it's likely a project supports either < 3.0.0 or >= 3.0.0 but not both. You could maybe run juicer in a virtual env. Pulp cannot run in a virtualenv unfortunately. I'm closing as NOTABUG since this issue should be filed against juicer instead. Please reopen if I've misunderstood the question.

[0]: https://github.com/pulp/pulp/blob/914f13505096e234f89eaa473c1b823cecf2041a/pulp.spec#L361

Actions #2

Updated by bmbouter over 4 years ago

  • Sprint set to June 2015
Actions #3

Updated by bmbouter over 4 years ago

  • Sprint/Milestone deleted (17)
Actions #4

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF