Project

Profile

Help

Task #153

closed

Determine how to add additional content protection

Added by mhrivnak almost 8 years ago. Updated over 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
February 2015
Quarter:

Description

In addition to our normal repo_auth WSGIAccessScript, some deployments need to do additional custom authorization. This task is to determine what the best way is to facilitate that. Ideally, we will be able to use apache to specify multiple methods.


Related issues

Is duplicate of Pulp - Story #720: As a pulp administrator, I would like to enable a custom auth check for content downloadsCLOSED - CURRENTRELEASEcduryee

Actions
Actions #1

Updated by cduryee almost 8 years ago

Is this task simply documenting how to add a plugin to https://github.com/pulp/pulp/blob/master/server/srv/pulp/repo_auth.wsgi#L21 or something more comprehensive?

Actions #2

Updated by mhrivnak almost 8 years ago

That's an option, although on first glance, it looks like the existing plugin system requires the upstream auth script to know about optional plugins in advance. It would be much better to allow arbitrary plugins to be added to a deployment. Ideally we'd be able to let apache handle this.

Actions #3

Updated by bmbouter almost 8 years ago

  • Tags Sprint Candidate added
Actions #4

Updated by mhrivnak almost 8 years ago

  • Sprint/Milestone set to 12
Actions #5

Updated by cduryee almost 8 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to cduryee
Actions #6

Updated by cduryee over 7 years ago

  • Status changed from ASSIGNED to POST

I emailed a few folks to get feedback for an idea for this. I will create a new task with details once I get feedback.

Actions #7

Updated by cduryee over 7 years ago

  • Status changed from POST to 7

Created https://pulp.plan.io/issues/720 to track this. Closing this task.

Actions #8

Updated by bmbouter over 7 years ago

  • Tags deleted (Sprint Candidate)
Actions #9

Updated by bmbouter over 7 years ago

  • Is duplicate of Story #720: As a pulp administrator, I would like to enable a custom auth check for content downloads added
Actions #10

Updated by bmbouter over 7 years ago

  • Status changed from 7 to CLOSED - DUPLICATE
Actions #11

Updated by bmbouter over 4 years ago

  • Sprint set to February 2015
Actions #12

Updated by bmbouter over 4 years ago

  • Sprint/Milestone deleted (12)
Actions #13

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF