Project

Profile

Help

Issue #1429

Unit docs are incorrect and should have all fields defined on models

Added by bmbouter almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

This is a documentation task to go through and update the yum types[0] and iso type[1] documentation to ensure they match the model definition in models.py

There is one known issue already:
- translated_name in missing from PackageGroup, PackageEnvironment, and PackageCategory

[0]: https://pulp-rpm.readthedocs.org/en/latest/tech-reference/yum-plugins.html#yum-types
[1]: https://pulp-rpm.readthedocs.org/en/latest/tech-reference/iso-plugins.html#iso-type


Related issues

Is duplicate of Pulp - Task #1522: Have types documentation autogenerate the docs from docstrings on mongoengine modelsCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bmbouter almost 6 years ago

  • Description updated (diff)

#2 Updated by mhrivnak almost 6 years ago

  • Triaged changed from No to Yes

#3 Updated by bmbouter over 5 years ago

  • Is duplicate of Task #1522: Have types documentation autogenerate the docs from docstrings on mongoengine models added

#4 Updated by bmbouter over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Platform Release deleted (2.8.0)

Closing because the duplicate issue will solve this issue in all plugins!

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF