Project

Profile

Help

Issue #1189

Puppet module upload failure error reporting is inconsistent with other tasks

Added by jsherril@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Uploading a puppet module that fails will lead you with something that looks like:


    pulp_tasks:
    - exception:
      task_type: pulp.server.managers.content.upload.import_uploaded_unit
      _href: /pulp/api/v2/tasks/12dc224e-1f63-4ba9-b6ac-67a005f2dc01/
      task_id: 12dc224e-1f63-4ba9-b6ac-67a005f2dc01
      tags:
      - pulp:repository:Default_Organization-rpmtest-puppet
      - pulp:action:import_upload
      finish_time: '2015-08-17T19:14:55Z'
      _ns: task_status
      start_time: '2015-08-17T19:14:55Z'
      traceback:
      spawned_tasks: []
      progress_report: {}
      queue: reserved_resource_worker-0@katello-devbox.example.com.dq
      state: finished
      worker_name: reserved_resource_worker-0@katello-devbox.example.com
      result:
        details: {}
        success_flag: false
        summary: /var/lib/pulp/uploads/1b855470-0b1f-4b3b-aed9-36254f5db6cb
      error:
      _id:
        $oid: 55d232afd4a07e2e6f201c66
      id: 55d232af84a09c078ddf1bc3
    poll_attempts:
      total: 1
      failed: 0

The 'state' should be error, not 'finished' like other tasks. 'success_flag' is a very odd way to indicate an error that i'm not sure is used elsewhere


Related issues

Is duplicate of Pulp - Issue #1747: Import upload task has unexpected/missing information on errorCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bcourt over 5 years ago

Two options:
1) pulp.server.managers.content.upload.ContentUploadManager#import_uploaded_unit should check status from the report generated by the plugin.
2) All the plugins upload code should raise an exception if the import fails.

The latter path vastly simpler in the long term.

#2 Updated by bcourt over 5 years ago

  • Priority changed from Normal to High
  • Triaged changed from No to Yes

#3 Updated by mhrivnak over 4 years ago

  • Is duplicate of Issue #1747: Import upload task has unexpected/missing information on error added

#4 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF