Project

Profile

Help

Issue #1183

As a developer, I can close this ticket as a duplicate of 1884 :)

Added by bmbouter over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Python:
Platform Release:
Target Release - Python:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 46
Quarter:

Description

See #1182

History

#1 Updated by jortel@redhat.com about 6 years ago

  • Description updated (diff)

#2 Updated by jortel@redhat.com about 6 years ago

  • Subject changed from Add ErrorDocument directive to python httpd conf to Update the apache configuration to support Lazy.
  • Description updated (diff)

#3 Updated by jortel@redhat.com about 6 years ago

  • Parent task deleted (#1180)

#4 Updated by jortel@redhat.com about 6 years ago

  • Checklist item changed from Add the necessary ErrorDocument directives to Update the directives

#5 Updated by amacdona@redhat.com over 5 years ago

  • Blocks Story #1884: As a user, I can lazily sync python packages added

#6 Updated by amacdona@redhat.com over 5 years ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#7 Updated by mhrivnak over 5 years ago

  • Sprint/Milestone set to 22

#8 Updated by mhrivnak over 5 years ago

  • Sprint/Milestone deleted (22)

#9 Updated by mhrivnak over 5 years ago

  • Sprint Candidate changed from Yes to No

#10 Updated by amacdona@redhat.com about 3 years ago

  • Checklist item deleted (Update the directives)
  • Checklist item deleted (Contains the necessary release note)
  • Subject changed from Update the apache configuration to support Lazy. to As a user, I can lazy sync a python repository
  • Groomed changed from Yes to No
  • Tags Pulp 3 added

Currently, there are no plans to support lazy sync for Pulp 2, so I am repurposing this issue for Pulp 3.

IMO, lazy should be implemented after we refactor to download the metadata in parallel. https://pulp.plan.io/issues/4132

After that refactor, the way to implement lazy will necessarily change from disincluding the ArtifactDownloader stages. There is not currently a pattern to implement lazy sync for projects that download multiple metadata files, but this problem is shared with Docker:
https://pulp.plan.io/issues/4174#note-2

#11 Updated by amacdona@redhat.com about 3 years ago

  • Blocked by Refactor #4132: Metadata is not downloaded in parallel added

#12 Updated by amacdona@redhat.com about 3 years ago

  • Blocks deleted (Story #1884: As a user, I can lazily sync python packages)

#13 Updated by amacdona@redhat.com about 3 years ago

  • Tracker changed from Task to Issue
  • Severity set to 2. Medium
  • Triaged set to No

#14 Updated by amacdona@redhat.com about 3 years ago

  • Blocked by deleted (Refactor #4132: Metadata is not downloaded in parallel)

#15 Updated by amacdona@redhat.com about 3 years ago

  • Subject changed from As a user, I can lazy sync a python repository to As a developer, I can close this ticket as a duplicate of 1884 :)
  • Sprint set to Sprint 46

#16 Updated by amacdona@redhat.com about 3 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#17 Updated by bmbouter over 2 years ago

  • Tags deleted (Pulp 3)

Also available in: Atom PDF