Project

Profile

Help

Issue #1099

Publish fails with error "Will not create a symlink to a non-existent source"

Added by brandor5 over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.2 Beta
Platform Release:
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When trying to publish a newly created repo I receive the following error:

[root@pulp ~]# pulp-admin rpm repo publish run --repo-id centos-6.4-x86_64-os
--------------------------------------------------------------------
Publishing Repository [centos-6.4-x86_64-os]
--------------------------------------------------------------------

This command may be exited via ctrl+c without affecting the request.

Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... failed
Will not create a symlink to a non-existent source
[/var/lib/pulp/content/distribution/ks-CentOS--6.4-x86_64/../../isos/x86_64/Cent
OS-6.4-x86_64-netinstall.iso]

Task Failed

Will not create a symlink to a non-existent source
[/var/lib/pulp/content/distribution/ks-CentOS--6.4-x86_64/../../isos/x86_64/Cent
OS-6.4-x86_64-netinstall.iso]

I've attached the logs that appear when this happen.

I hopped onto #pulp earlier today and spoke with users mhrivnak and bcourt. They pointed out that the error was caused by a bad path in .treeinfo (the boot.iso value in http://vault.centos.org/6.4/os/x86_64/.treeinfo).

If there is anything more I can do to help with this issue, please let me know.

Thanks,
Brandon

pulp-error.txt (5 KB) pulp-error.txt error log brandor5, 07/01/2015 01:59 AM

History

#1 Updated by mhrivnak over 6 years ago

  • Priority changed from Normal to Low
  • Triaged changed from No to Yes

#2 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 2 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF