Project

Profile

Help

Pulp 2 10 3 Test Result Summary

Summary

Started On: 21 November 2016
Finished On: 1 December 2016
Version: 2.10.3
Result : Success
Build URL: N/A
Summary

This release included bug fixes. The QE tasks included in the release process included manual verification some of the issues included in the release, making sure automation jobs pass and upgrade automation jobs passing.

The upgrade automation failure on RHEL6 was identified as a problem not with Pulp, but with how the upgrade is performed. Pulp 2.8 is installed using ansible. Then the upgrade is performed using a bash script that Jenkins runs. As a result, when the the services are started after the upgrade the pid files started in the java_t context. When pulp-smash, or anything else, tries to stop the services the following denial is recorded in the audit.log:

type=AVC msg=audit(1480428276.495:3071): avc: denied { signal } for pid=23019 comm="celery" scontext=unconfined_u:system_r:celery_t:s0 tcontext=unconfined_u:system_r:unconfined_java_t:s0-s0:c0.c1023 tclass=process

The above log says that a signal being sent by command 'celery' that has the unconfined_u:system_r:celery_t:s0 context is being denied. The signal is being sent to a process running in the unconfined_u:system_r:unconfined_java_t:s0-s0:c0.c1023 context.

The solution is to convert the upgrade job from a bash script to an ansible playbook.

Due to this failure upgrade on RHEL 6 was done manually and tests passed.

  • Pulp QE approve the release of pulp 2.10.3 *

Beta History
Beta 1: 21 November 2016

*Bugs Included *

2354 RPM Support Incorrect URL on lazy catalog entries created for existing RPM content units
2362 RPM Support applicability calculation wastes time scanning a list
2374 RPM Support Can't skip distribution content during sync
2436 Pulp pulp-selinux RPM fails to run restorecon statements post install
2195 Pulp can't sync unit that was previously uploaded
2372 RPM Support updating importer ssl_client_cert to null fails with error
2424 Pulp restorecon runs unecessarily for all 2.10+ upgrades

*New Issues Filed *
https://pulp.plan.io/issues/245

*Action Items

  • Add new pulp smash issues verify the selinux context.

https://github.com/PulpQE/pulp-smash/issues/442

Also available in: PDF HTML ODT TXT