Project

Profile

Help

Story #7646

Updated by mdepaulo@redhat.com 12 months ago

Currently, the following situation/issue is occurring:
1. A user installs pulp from RPM packages from a 3rd-party repo. Such as with pulpcore 3.4 and dynaconf 3.0.0rc1.
2. The repo gets updated (or the user specifies a new URL for the repo, `pulp_pkg_repo` with newer packages.)
3. The new the repo has pulpcore 3.7 and dynaconf 3.1.1.
4. pulpcore 3.7 requires dynaconf >= 3.0.0 (python/pip dependency), but the RPM packaging / RPM itself incorrectly enumerates 3.0.0rc1 as an acceptable version (3.0.0-0.1.rc1 is technically >= 3.0.0).
5. The user runs the installer with pulp_pkg_upgrade_all, and it upgrades pulpcore, but dynaconf is still on 3.0.0rc1 rather than dynaconf 3.11.
6. The installer fails on on collectstatic due to the dynaconf version detection by python/pip.

https://projects.theforeman.org/issues/30963

After conversing with the Foreman devs, this is a bug in their repo that they will fix, but the installer should still prevent situations like this from happening. The repo is meant to be updated as a single unit, not only certain packages. So the installer should updated as a single unit.

Back