Project

Profile

Help

Task #3198

Updated by dalley almost 6 years ago

3.0-dev branch already exists for pulp_rpm: https://github.com/pulp/pulp_rpm/tree/3.0-dev 

 This task is complete when 

 1.    The plugin is discoverable by Pulp 
 2.    CRUD for ContentUnits, Importers, Publishers works (vanilla, without RPM specific fields) 
 3.    The correct PyPi metadata and license is present 

 To make 3.0-dev branch ready for development, we should remove Pulp 2 code and documentation and populate this branch with code generated by "plugin_template" [0] (follow README instructions). 

 We should retain the LICENSE and AUTHORS files, and repopulate the metadata in setup.py with the information present in the old setup.py.    We also need to replace the README e.g. [1] 

 [0] https://github.com/pulp/plugin_template 
 [1] https://github.com/pulp/pulp_python/blob/3.0-dev/README.rst 

Back