Project

Profile

Help

Issue #9675

closed

pulp.pulp_installer.pulp_common : Run pip-compile to check pulpcore/plugin compatibility]

Added by mhsmith 5 months ago. Updated 3 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Packaging:
Platform Release:
Target Release - Packaging:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

When running the an initial install, using the ansible installer version 3.17.0 I get the following error:

fatal: [gazza-boy]: FAILED! => {"changed": false, "cmd": ["/usr/local/lib/pulp/bin/pip-compile"], "delta": "0:00:00.641376", "end": "2022-02-01 13:52:47.438926", "failed_when_result": true, "msg": "non-zero return code", "rc": 1, "start": "2022-02-01 13:52:46.797550", "stderr": "Traceback (most recent call last):\n File "/usr/local/lib/pulp/bin/pip-compile", line 8, in \n sys.exit(cli())\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1128, in call\n return self.main(*args, **kwargs)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1053, in main\n rv = self.invoke(ctx)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1395, in invoke\n return ctx.invoke(self.callback, **ctx.params)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 754, in invoke\n return __callback(*args, **kwargs)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/decorators.py", line 26, in new_func\n return f(get_current_context(), *args, **kwargs)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/scripts/compile.py", line 342, in cli\n repository = PyPIRepository(pip_args, cache_dir=cache_dir)\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/repositories/pypi.py", line 106, in init\n self._setup_logging()\n File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/repositories/pypi.py", line 455, in _setup_logging\n assert isinstance(handler, logging.StreamHandler)\nAssertionError", "stderr_lines": ["Traceback (most recent call last):", " File "/usr/local/lib/pulp/bin/pip-compile", line 8, in ", " sys.exit(cli())", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1128, in call", " return self.main(*args, **kwargs)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1053, in main", " rv = self.invoke(ctx)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 1395, in invoke", " return ctx.invoke(self.callback, **ctx.params)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/core.py", line 754, in invoke", " return __callback(*args, **kwargs)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/click/decorators.py", line 26, in new_func", " return f(get_current_context(), *args, **kwargs)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/scripts/compile.py", line 342, in cli", " repository = PyPIRepository(pip_args, cache_dir=cache_dir)", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/repositories/pypi.py", line 106, in init", " self._setup_logging()", " File "/usr/local/lib/pulp/lib64/python3.8/site-packages/piptools/repositories/pypi.py", line 455, in _setup_logging", " assert isinstance(handler, logging.StreamHandler)", "AssertionError"], "stdout": "", "stdout_lines": []}

Actions #1

Updated by mhsmith 5 months ago

I posted an issue over on github https://github.com/pulp/pulp_installer/issues/872

This has been was fixed on 3.17.2 which worked for me...

Actions #2

Updated by ttereshc 3 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Thanks for filing it on github. We did move our tracking there, and this one should be read-only soon.

Also available in: Atom PDF