Project

Profile

Help

Issue #9196

Creating publication : C_CREATEREPOLIB-WARNING - Publication matching query does not exist

Added by janr7 about 2 months ago. Updated about 1 month ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Hello

We are installing a new pulp3 docker container. pulp "version": "3.14.2"

If I am at the wrong place to log this issue, please redirect me to the correct place as this is a first ever with pulp for me.

Creating publications for of 4 out of 5 repositories worked. one at version 0 (no content) three at version 1

The one repository at Version 2 is failing.

Attached are the docker log and the command output with vlag-vvv The top of the command log is output of repository list and publication list.

The content for the failing repository were updated to rev 2 yesterday

Failing command: pulp rpm publication create --repository "SLES12-SP5-Updates"

Failing publication: (info from log file) "latest_version_href": "/pulp/api/v3/repositories/rpm/rpm/d04fd14e-fe1c-4638-8cf6-9a6a508224e2/versions/2/", "name": "SLES12-SP5-Updates",

pulp_publication_error_docker-log.log (48.2 KB) pulp_publication_error_docker-log.log docker logfile janr7, 08/03/2021 02:39 PM
pulp_publication_create-vvv.log (363 KB) pulp_publication_create-vvv.log create command error janr7, 08/03/2021 02:39 PM

Related issues

Is duplicate of Pulp - Issue #9174: Cache invalidation code for publication delete triggers an error when no complete publication yet existsCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by janr7 about 2 months ago

Thank you so much for the help!!

#2 Updated by dalley about 2 months ago

I'm about 90% certain that this is the same as https://pulp.plan.io/issues/9174 which was fixed earlier today, so hopefully the next release (3.14.4 or 3.15.0) will resolve it.

#3 Updated by dalley about 2 months ago

  • Is duplicate of Issue #9174: Cache invalidation code for publication delete triggers an error when no complete publication yet exists added

#4 Updated by dalley about 2 months ago

I'll leave it open for now because I'm not 100% certain :)

#5 Updated by janr7 about 2 months ago

Hi, this is such good news.

It would be really appreciated for 3.14.4 to help us move on quicker. Are there a way to watch/follow the ETA for the fix?

Thank you once more.

#6 Updated by mdepaulo@redhat.com about 2 months ago

  • Category deleted (Installer)

#7 Updated by dalley about 1 month ago

  • Status changed from NEW to CLOSED - WORKSFORME

@janr7 pulpcore 3.14.4 is now released, and the image should now be updated as well. Let me know whether this fixes your issue!

#8 Updated by dalley about 1 month ago

  • Status changed from CLOSED - WORKSFORME to CLOSED - DUPLICATE

#9 Updated by janr7 about 1 month ago

Hello dalley, 3.14.4 is working just fine.

Thanks you so much. Appreciated.

Please register to edit this issue

Also available in: Atom PDF