Project

Profile

Help

Issue #9190

closed

Problem syncing rpm-repo for bacula enterprise

Added by Langesmalle about 1 year ago. Updated about 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

I'm having a problem syncing the bweb repo from Bacula Enterprise Edition.

For more details, please see: https://community.theforeman.org/t/problem-syncing-rpm-repo-for-bacula-enterprise/24679

Please find in attachment the repomd.xml file from the Dependencies folder as Sherrill Justin mentioned in his reply.

Please let me know if additional information is required.


Files

repomd.xml (2.92 KB) repomd.xml Langesmalle, 08/02/2021 09:13 AM
Actions #1

Updated by dalley about 1 year ago

  • Project changed from Pulp to RPM Support
Actions #2

Updated by dalley about 1 year ago

  • Tags Katello added
Actions #3

Updated by dalley about 1 year ago

I don't have access to the enterprise edition repos so I can't do an apples-to-apples reproduction, but just browsing the repos for their community edition (from an actual browser) I was able to reproduce the "looping" behavior.

https://www.bacula.org/packages/5bd703346c037/bacula/

if you keep clicking on "backula" it will just keep recursing into deeper and deeper subdirectories, e.g.

https://www.bacula.org/packages/5bd703346c037/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/bacula/

So it's not immediately clear whether this is an actual Pulp bug or caused by their web hosting - at least not without the ability to access the repos you're looking at.

Since you have access, you take a look at {repo+creds}/rpms/bweb/12.8.1/rhel7-64/, open primary.xml.gz, find the "perl-Net-SSH-Perl-1.34-1.el7.centos.noarch.rpm" package, look at the location_href value, append it to the repository, and then try to download the file it's pointing to with "curl -I -L $url"?

This will print out the response headers if/when it tries to redirect you.

Actions #4

Updated by dalley about 1 year ago

Unrelated sidenote: visiting https://www.baculasystems.com/dl/ will raise 500 server error, so their IT practices seem a little suspect :)

Actions #5

Updated by Langesmalle about 1 year ago

Hi, The primary.xml.gz file from Bacula was indeed not correct. After they modified it were able to sync the repo within foreman.

Thnx for your feedback. Issue can be closed.

Actions #6

Updated by dalley about 1 year ago

  • Status changed from NEW to CLOSED - NOTABUG

No problem! Thanks for your interest.

Also available in: Atom PDF