Project

Profile

Help

Issue #9022

errors fetching repomd.xml will fail with python error 'local variable 'result' referenced before assignment'

Added by jsherril@redhat.com 3 months ago. Updated 3 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

File "/usr/lib/python3.6/site-packages/rq/worker.py", line 1013, in perform_job
rv = job.perform()
File "/usr/lib/python3.6/site-packages/rq/job.py", line 709, in perform
self._result = self._execute()
File "/usr/lib/python3.6/site-packages/rq/job.py", line 732, in _execute
result = self.func(*self.args, **self.kwargs)
File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 227, in synchronize
remote_url = fetch_remote_url(remote)
File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 141, in fetch_remote_url
if get_repomd_file(remote, remote_url):
File "/usr/lib/python3.6/site-packages/pulp_rpm/app/tasks/synchronizing.py", line 110, in get_repomd_file
return result
UnboundLocalError: local variable 'result' referenced before assignment

https://github.com/pulp/pulp_rpm/blob/440155ba24c296c982c329e76cb3768c0bac53e9/pulp_rpm/app/tasks/synchronizing.py#L205


Related issues

Is duplicate of RPM Support - Issue #8787: "UnboundLocalError: local variable 'result' referenced before assignment" on attempt to sync some reposCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jsherril@redhat.com 3 months ago

  • Project changed from Pulp to RPM Support

#2 Updated by dalley 3 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by dalley 3 months ago

  • Is duplicate of Issue #8787: "UnboundLocalError: local variable 'result' referenced before assignment" on attempt to sync some repos added

Please register to edit this issue

Also available in: Atom PDF