Project

Profile

Help

Issue #8796

`pulpcore-manager` failed for AttributeError: 'Settings' object has no attribute 'CONTENT_ORIGIN'

Added by xzhang1 4 months ago. Updated 4 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
05/24/2021
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

sudo docker pull pulp/pulp

sudo docker run --detach --publish 8090:80 --name pulp --volume "$(pwd)/settings":/etc/pulp --volume "$(pwd)/pulp_storage":/var/lib/pulp --volume "$(pwd)/pgsql":/var/lib/pgsql --volume "$(pwd)/containers":/var/lib/containers --device /dev/fuse pulp/pulp

sudo docker exec pulp bash -c 'pulpcore-manager reset-admin-password -p admin'

Traceback (most recent call last): File "/usr/local/bin/pulpcore-manager", line 8, in ... File "/usr/local/lib/python3.6/site-packages/pulp_ansible/app/settings.py", line 24, in ANSIBLE_CONTENT_HOSTNAME = settings.CONTENT_ORIGIN + "/pulp/content" File "/usr/local/lib/python3.6/site-packages/dynaconf/base.py", line 168, in getattr value = getattr(self._wrapped, name) File "/usr/local/lib/python3.6/site-packages/dynaconf/base.py", line 301, in getattribute return super().getattribute(name) AttributeError: 'Settings' object has no attribute 'CONTENT_ORIGIN'

History

#1 Updated by xzhang1 4 months ago

Root cause find. lack operation below: $ echo "CONTENT_ORIGIN='http://$(hostname):8080' ANSIBLE_API_HOSTNAME='http://$(hostname):8080' ANSIBLE_CONTENT_HOSTNAME='http://$(hostname):8080/pulp/content' TOKEN_AUTH_DISABLED=True" >> settings/settings.py

Please just close this case.

Sorry

#2 Updated by daviddavis 4 months ago

  • Status changed from NEW to CLOSED - WORKSFORME

Please register to edit this issue

Also available in: Atom PDF