Project

Profile

Help

Issue #8531

"Getting started" guide fails at redis

Added by luto 6 months ago. Updated 6 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Following the getting started guide on CentOS 7 yields this error for me:

TASK [pulp.pulp_installer.pulp_redis : Install Redis] **************************
fatal: [default]: FAILED! => {"changed": false, "msg": "No package matching 'redis' found available, installed or updated", "rc": 126, "results": ["No package matching 'redis' found available, installed or updated"]}

Installed versions:

$ ansible-galaxy collection list | grep -i pulp
pulp.pulp_installer 3.11.0 
$ ansible-galaxy role list | grep -i post
- geerlingguy.postgresql, 3.1.0

It seems like the pulp_common role, which is in charge of enabling EPEL, does not run before the redis one does.

You can see my test setup including a vagrant file here: https://github.com/luto/pulp_test

Any hints on where I went wrong? :)


Related issues

Is duplicate of Pulp - Issue #7773: pulp_installer fails to install redis due to no EPEL7CLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by luto 6 months ago

duplicate of #7773.. my issue searching skills are not awake yet, apparently.

#2 Updated by mdepaulo@redhat.com 6 months ago

  • Is duplicate of Issue #7773: pulp_installer fails to install redis due to no EPEL7 added

#3 Updated by mdepaulo@redhat.com 6 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF