Project

Profile

Help

Issue #7405

ValueError: DeclarativeArtifact must have a 'remote'

Added by ttereshc about 1 year ago. Updated 12 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

If a pulp 2 importer has on_demand policy and its feed is changed and no sync performed, the failure below happens.

To reproduce:

  • sync an rpm repo in pulp 2
  • migrate it to pulp 3
  • update the importer's feed in pulp 2, do not re-sync
  • migrate to pulp 3
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: pulp: rq.worker:ERROR: ValueError: DeclarativeArtifact must have a 'remote' if the Artifact doesn't have a file backing it.
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: Traceback (most recent call last):
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/worker.py", line 883, in perform_job
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: rv = job.perform()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py", line 657, in perform
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: self._result = self._execute()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py", line 663, in _execute
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: return self.func(*self.args, **self.kwargs)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/tasks/migrate.py", line 141, in migrate_from_pulp2
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: migrate_content(plan)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/migration.py", line 36, in migrate_content
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: plugin.migrator.migrate_content_to_pulp3()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/rpm/migrator.py", line 141, in migrate_content_to_pulp3
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: loop.run_until_complete(dm.create())
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/lib64/python3.6/asyncio/base_events.py", line 484, in run_until_complete
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: return future.result()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 86, in create
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await pipeline
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await asyncio.gather(*futures)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 43, in __call__
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await self.run()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 191, in run
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: self.migrate_to_pulp3(cmodel, ctype)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 319, in migrate_to_pulp3
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: deferred_download=not downloaded)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/models.py", line 57, in __init__
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: "DeclarativeArtifact must have a 'remote' if the Artifact doesn't "
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: ValueError: DeclarativeArtifact must have a 'remote' if the Artifact doesn't have a file backing it.
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: Traceback (most recent call last):
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/worker.py", line 883, in perform_job
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: rv = job.perform()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py", line 657, in perform
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: self._result = self._execute()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py", line 663, in _execute
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: return self.func(*self.args, **self.kwargs)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/tasks/migrate.py", line 141, in migrate_from_pulp2
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: migrate_content(plan)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/migration.py", line 36, in migrate_content
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: plugin.migrator.migrate_content_to_pulp3()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/rpm/migrator.py", line 141, in migrate_content_to_pulp3
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: loop.run_until_complete(dm.create())
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/usr/lib64/python3.6/asyncio/base_events.py", line 484, in run_until_complete
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: return future.result()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 86, in create
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await pipeline
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 225, in create_pipeline
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await asyncio.gather(*futures)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/api.py", line 43, in __call__
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: await self.run()
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 191, in run
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: self.migrate_to_pulp3(cmodel, ctype)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulp-2to3-migration/pulp_2to3_migration/app/plugin/content.py", line 319, in migrate_to_pulp3
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: deferred_download=not downloaded)
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: File "/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/models.py", line 57, in __init__
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: "DeclarativeArtifact must have a 'remote' if the Artifact doesn't "
Aug 27 19:36:18 pulp2-nightly-pulp3-source-centos7.rhgoose.example.com rq[31497]: ValueError: DeclarativeArtifact must have a 'remote' if the Artifact doesn't have a file backing it.

History

#1 Updated by dalley about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dalley

#2 Updated by dalley 12 months ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

I tried a 4 week old build and still couldn't reproduce this with several repos including the centos8-kickstart repo. I'm going to close this for now, if we re-encounter it in a specific instance then hopefully we can proceed.

Please register to edit this issue

Also available in: Atom PDF