Project

Profile

Help

Story #6017

Story #4762: [Epic] As a user, I can copy content

[Epic] As a user, when copying content, dependencies of that content are also copied

Added by dalley 9 months ago. Updated 5 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
(Total: 0:00 h)
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This epic will track the state of dependency resolution when performing copy operations using the RPM plugin.

When copying RPMs, Modules, and Errata from one repository to another, it is often necessary to ensure that the destination repository contains all the dependencies those units require to function correctly. For instance, if you copy the "foo" package to a repository that does not contain foo's dependencies "bar" and "baz", clients may not be able to install the "foo" package and the repository would not work as intended.

Therefore, it is useful for Pulp to be able to resolve those dependencies and include them in the copy operation even though the user did not explicitly specify them.


Subtasks

Story #4162: As a user, I have dependency solving when copying modulesCLOSED - CURRENTRELEASEdalley

Actions
Story #4761: As a user, I have RPM dependency solvingCLOSED - CURRENTRELEASEdalley

Actions
Story #4768: As a user, I can copy Erratum with their referenced Modules and RPMs, and their dependenciesCLOSED - CURRENTRELEASEdalley

Actions

History

#1 Updated by dalley 9 months ago

  • Parent task set to #4762

#2 Updated by dalley 8 months ago

  • Status changed from NEW to MODIFIED

All subtasks complete

#3 Updated by dalley 6 months ago

  • Sprint/Milestone set to Pulp RPM 3.3.0

#4 Updated by dalley 6 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#5 Updated by dalley 5 months ago

  • Assignee set to dalley

Please register to edit this issue

Also available in: Atom PDF