Project

Profile

Help

Task #5542

Have Travis publish our plugin docs

Added by daviddavis about 1 year ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Using RTD, we're limited to using their build process which requires us to do things like check in our api schema to source control. It would be better to have Travis build our docs. This will probably require us to move off RTD and use something like github pages instead.


Related issues

Related to Pulp - Task #5541: Have Travis check whether api.json is up to dateCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Task #7229: publish plugin documentation at docs.pulpproject.orgPOST

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by daviddavis about 1 year ago

  • Related to Task #5541: Have Travis check whether api.json is up to date added

#2 Updated by daviddavis about 1 year ago

Here's a guide on how to publish docs to github pages via Travis:

https://sphinxtechnicalwriting.readthedocs.io/en/latest/cd/config-travis.html

#3 Updated by daviddavis about 1 year ago

  • Tracker changed from Issue to Task
  • % Done set to 0

#4 Updated by daviddavis about 2 months ago

  • Is duplicate of Task #7229: publish plugin documentation at docs.pulpproject.org added

#5 Updated by daviddavis about 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF